summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-05-31 01:09:29 +0000
committerDon Seiler <rizzo@gentoo.org>2004-05-31 01:09:29 +0000
commitcc4a08731190a6a5442a977494bdfd0ad41a110e (patch)
treec4e6ca687e33748e688501e4c2b71d7d61ca599e /net-im/gaim-encryption
parentAdded exim to new mailwrapper list (diff)
downloadgentoo-2-cc4a08731190a6a5442a977494bdfd0ad41a110e.tar.gz
gentoo-2-cc4a08731190a6a5442a977494bdfd0ad41a110e.tar.bz2
gentoo-2-cc4a08731190a6a5442a977494bdfd0ad41a110e.zip
Version bump
Diffstat (limited to 'net-im/gaim-encryption')
-rw-r--r--net-im/gaim-encryption/ChangeLog7
-rw-r--r--net-im/gaim-encryption/files/digest-gaim-encryption-2.261
-rw-r--r--net-im/gaim-encryption/gaim-encryption-2.26.ebuild49
3 files changed, 56 insertions, 1 deletions
diff --git a/net-im/gaim-encryption/ChangeLog b/net-im/gaim-encryption/ChangeLog
index 488c68784765..0545ae6864de 100644
--- a/net-im/gaim-encryption/ChangeLog
+++ b/net-im/gaim-encryption/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim-encryption
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.29 2004/05/26 13:15:03 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.30 2004/05/31 01:09:29 rizzo Exp $
+
+*gaim-encryption-2.26 (30 May 2004)
+
+ 30 May 2004; Don Seiler <rizzo@gentoo.org>; +gaim-encryption-2.26.ebuild:
+ Version bump
26 May 2004; Guy Martin <gmsoft@gentoo.org> gaim-encryption-2.25.ebuild:
Marked stable on hppa.
diff --git a/net-im/gaim-encryption/files/digest-gaim-encryption-2.26 b/net-im/gaim-encryption/files/digest-gaim-encryption-2.26
new file mode 100644
index 000000000000..006c4ac8fb2c
--- /dev/null
+++ b/net-im/gaim-encryption/files/digest-gaim-encryption-2.26
@@ -0,0 +1 @@
+MD5 950e7421b301c34bd6cf5b8fcaafccc3 gaim-encryption-2.26.tar.gz 362436
diff --git a/net-im/gaim-encryption/gaim-encryption-2.26.ebuild b/net-im/gaim-encryption/gaim-encryption-2.26.ebuild
new file mode 100644
index 000000000000..2736eb6700c6
--- /dev/null
+++ b/net-im/gaim-encryption/gaim-encryption-2.26.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/gaim-encryption-2.26.ebuild,v 1.1 2004/05/31 01:09:29 rizzo Exp $
+
+inherit flag-o-matic eutils
+use debug && inherit debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~hppa ~mips"
+IUSE="debug"
+
+DEPEND=">=net-im/gaim-0.78
+ dev-libs/nss"
+
+src_compile() {
+ local myconf
+ myconf="--with-gaim=/usr/include/gaim"
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || emake -j1 || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG COPYING INSTALL NOTES README TODO VERSION WISHLIST
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "This release is not backwards compatible for MSN, Yahoo, or IRC."
+ ewarn "See the release notes at:"
+ ewarn "https://sourceforge.net/project/shownotes.php?release_id=230104"
+ ewarn
+}