summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-14 19:58:10 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-14 19:58:10 +0000
commitb7fc6b511f8974f406b8304f3422575ac7025568 (patch)
tree5d59e8786cde38a226fa27a65a33834bed0cf10e /net-im/gajim
parentUse LDFLAGS when linking (diff)
downloadgentoo-2-b7fc6b511f8974f406b8304f3422575ac7025568.tar.gz
gentoo-2-b7fc6b511f8974f406b8304f3422575ac7025568.tar.bz2
gentoo-2-b7fc6b511f8974f406b8304f3422575ac7025568.zip
Fix for bug 315103
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/files/0.13.4-python-version.patch13
-rw-r--r--net-im/gajim/gajim-0.13.4-r1.ebuild107
3 files changed, 127 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 95cfc64ebf49..ab48fba8ee42 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.94 2010/04/02 11:54:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.95 2010/04/14 19:58:10 jlec Exp $
+
+*gajim-0.13.4-r1 (14 Apr 2010)
+
+ 14 Apr 2010; Justin Lecher <jlec@gentoo.org> +gajim-0.13.4-r1.ebuild:
+ Move to new Python ABI situation, fixes #315103
+ We do byte-compile ourself
*gajim-0.13.4 (02 Apr 2010)
diff --git a/net-im/gajim/files/0.13.4-python-version.patch b/net-im/gajim/files/0.13.4-python-version.patch
new file mode 100644
index 000000000000..1fbc503e244a
--- /dev/null
+++ b/net-im/gajim/files/0.13.4-python-version.patch
@@ -0,0 +1,13 @@
+diff --git a/scripts/gajim.in b/scripts/gajim.in
+index 711ddac..0098b9e 100644
+--- a/scripts/gajim.in
++++ b/scripts/gajim.in
+@@ -30,7 +30,7 @@ fi
+ [ "$APP" = "gajim-history-manager" ] && APP="history_manager"
+
+ export datadir=@DATADIR@/gajim
+-PYTHON_EXEC=@PYTHON@
++PYTHON_EXEC=@PYTHON@@PYTHON_VERSION@
+
+ cd ${datadir}/src
+ export PYTHONPATH="$PYTHONPATH:@LIBDIR@/gajim"
diff --git a/net-im/gajim/gajim-0.13.4-r1.ebuild b/net-im/gajim/gajim-0.13.4-r1.ebuild
new file mode 100644
index 000000000000..59404b63d46a
--- /dev/null
+++ b/net-im/gajim/gajim-0.13.4-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.13.4-r1.ebuild,v 1.1 2010/04/14 19:58:10 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+inherit autotools eutils python versionator
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt dbus gnome idle libnotify nls spell srv trayicon X xhtml"
+
+COMMON_DEPEND=">=dev-python/pygtk-2.12.0"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17-r1
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyopenssl
+ dev-python/sexy-python
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ trayicon? ( dev-python/egg-python )
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ fi
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # install pyfiles in /usr/lib/python2.x/site-packages/gajim
+ # upstream: http://trac.gajim.org/ticket/5460
+ # Should be in 0.14
+ epatch "${FILESDIR}/${PN}-0.13-autotools--enable-site-packages_option.patch"
+ epatch "${FILESDIR}"/${PV}-python-version.patch
+ eautoreconf
+ echo '#!/bin/sh' > config/py-compile
+}
+
+src_configure() {
+ local myconf
+
+ if ! use gnome; then
+ myconf+=" $(use_enable trayicon)"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
+ --enable-site-packages \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
+ dohtml README.html || die
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}