summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-18 08:45:42 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-18 08:45:42 +0000
commitedc08030ba22b28c77e1b4989ccb368d685e8b51 (patch)
tree8ea0741e5095ffec40cfb460fee613536f8a1ccd /net-im/gajim
parent[bump] dev-perl/Olson-Abbreviations-0.40.0 (diff)
downloadgentoo-2-edc08030ba22b28c77e1b4989ccb368d685e8b51.tar.gz
gentoo-2-edc08030ba22b28c77e1b4989ccb368d685e8b51.tar.bz2
gentoo-2-edc08030ba22b28c77e1b4989ccb368d685e8b51.zip
net-im/gajim: Version BUmp; include backport of last tab closed fix, #461248
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/files/gajim-0.15.3-roster.patch31
-rw-r--r--net-im/gajim/gajim-0.15.3.ebuild119
3 files changed, 157 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 5e8af4f702a3..60985519f07b 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.172 2013/02/23 10:32:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.173 2013/03/18 08:45:41 jlec Exp $
+
+*gajim-0.15.3 (18 Mar 2013)
+
+ 18 Mar 2013; Justin Lecher <jlec@gentoo.org> +gajim-0.15.3.ebuild,
+ +files/gajim-0.15.3-roster.patch:
+ Version BUmp; include backport of last tab closed fix, #461248
*gajim-0.15.2-r4 (23 Feb 2013)
diff --git a/net-im/gajim/files/gajim-0.15.3-roster.patch b/net-im/gajim/files/gajim-0.15.3-roster.patch
new file mode 100644
index 000000000000..9b3498daf591
--- /dev/null
+++ b/net-im/gajim/files/gajim-0.15.3-roster.patch
@@ -0,0 +1,31 @@
+Index: src/common/config.py
+===================================================================
+--- src/common/config.py (revision 14330)
++++ src/common/config.py (revision 14450)
+@@ -163,4 +163,5 @@
+ 'roster_width': [ opt_int, 200 ],
+ 'roster_height': [ opt_int, 400 ],
++ 'roster_hpaned_position': [opt_int, 200],
+ 'history_window_width': [ opt_int, 650 ],
+ 'history_window_height': [ opt_int, 450 ],
+Index: src/message_window.py
+===================================================================
+--- src/message_window.py (revision 14114)
++++ src/message_window.py (revision 14450)
+@@ -1000,5 +1000,5 @@
+ win.resize(size[0], size[1])
+ if win.parent_paned:
+- win.parent_paned.set_position(parent_size[0])
++ win.parent_paned.set_position(gajim.config.get('roster_hpaned_position'))
+
+ def _position_window(self, win, acct, type_):
+Index: src/roster_window.py
+===================================================================
+--- src/roster_window.py (revision 14436)
++++ src/roster_window.py (revision 14450)
+@@ -4492,4 +4492,5 @@
+ roster_width = pane.get_child1().allocation.width
+ gajim.config.set('roster_width', roster_width)
++ gajim.config.set('roster_hpaned_position', pane.get_position())
+
+ ################################################################################
diff --git a/net-im/gajim/gajim-0.15.3.ebuild b/net-im/gajim/gajim-0.15.3.ebuild
new file mode 100644
index 000000000000..673b089f31be
--- /dev/null
+++ b/net-im/gajim/gajim-0.15.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.15.3.ebuild,v 1.1 2013/03/18 08:45:41 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite xml"
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils python-r1 versionator
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="
+ http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+# test? ( http://dev.gentoo.org/~jlec/distfiles/${PN}-tests-${PV}.tar.xz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt dbus gnome kde idle jingle libnotify networkmanager nls spell +srv test X xhtml"
+
+REQUIRED_USE="
+ libnotify? ( dbus )
+ avahi? ( dbus )"
+
+COMMON_DEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+ dbus? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ dev-python/egg-python
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ jingle? ( net-libs/farstream:0.1[python] )
+ kde? ( kde-base/kwallet )
+ networkmanager? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ net-misc/networkmanager
+ )
+ spell? ( app-text/gtkspell:2 )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ xhtml? ( dev-python/docutils )"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-roster.patch
+ )
+
+src_prepare() {
+ echo "src/command_system/mapping.py" >> po/POTFILES.in
+ echo '#!/bin/sh' > config/py-compile
+ autotools-utils_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_with X x)
+ --docdir="/usr/share/doc/${PF}"
+ --libdir="$(python_get_sitedir)"
+ --enable-site-packages
+ )
+ run_in_build_dir autotools-utils_src_configure
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ compilation() {
+ run_in_build_dir autotools-utils_src_compile
+ }
+ python_foreach_impl compilation
+}
+
+src_test() {
+ testing() {
+ run_in_build_dir ${PYTHON} test/runtests.py --verbose 3 || die
+ }
+ python_foreach_impl testing
+}
+
+src_install() {
+ installation() {
+ run_in_build_dir autotools-utils_src_install
+ python_optimize "${ED}"/$(python_get_sitedir)
+ }
+ python_foreach_impl installation
+
+ rm "${D}/usr/share/doc/${PF}/README.html" || die
+ dohtml README.html
+}