summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-26 01:17:19 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-26 01:17:19 +0000
commite96f59b6f94df44d3e60d87cf01e3fc14ddd2c8e (patch)
treed21545aab0311ac6d10cdc858b43a2582b02e606 /net-im/ktp-contact-list
parentbump - 508688 (diff)
downloadgentoo-2-e96f59b6f94df44d3e60d87cf01e3fc14ddd2c8e.tar.gz
gentoo-2-e96f59b6f94df44d3e60d87cf01e3fc14ddd2c8e.tar.bz2
gentoo-2-e96f59b6f94df44d3e60d87cf01e3fc14ddd2c8e.zip
Version bump KDE Telepathy 0.8.1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-im/ktp-contact-list')
-rw-r--r--net-im/ktp-contact-list/ChangeLog7
-rw-r--r--net-im/ktp-contact-list/ktp-contact-list-0.8.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-im/ktp-contact-list/ChangeLog b/net-im/ktp-contact-list/ChangeLog
index 93e4f8375961..3241a7ccba58 100644
--- a/net-im/ktp-contact-list/ChangeLog
+++ b/net-im/ktp-contact-list/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/ktp-contact-list
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-list/ChangeLog,v 1.25 2014/04/12 13:20:50 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-list/ChangeLog,v 1.26 2014/04/26 01:17:17 johu Exp $
+
+*ktp-contact-list-0.8.1 (26 Apr 2014)
+
+ 26 Apr 2014; Johannes Huber <johu@gentoo.org> +ktp-contact-list-0.8.1.ebuild:
+ Version bump KDE Telepathy 0.8.1.
12 Apr 2014; Johannes Huber <johu@gentoo.org> ktp-contact-list-0.8.0.ebuild:
Add semantic-desktop use flag by Uwe L. Korn <uwelk@xhochy.com>.
diff --git a/net-im/ktp-contact-list/ktp-contact-list-0.8.1.ebuild b/net-im/ktp-contact-list/ktp-contact-list-0.8.1.ebuild
new file mode 100644
index 000000000000..e8460875baee
--- /dev/null
+++ b/net-im/ktp-contact-list/ktp-contact-list-0.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-list/ktp-contact-list-0.8.1.ebuild,v 1.1 2014/04/26 01:17:17 johu Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el es et fi fr ga gl hu ia it ja kk km
+ko lt mr nb nds nl pl pt pt_BR ro ru sk sl sr sr@ijekavian sr@ijekavianlatin
+sr@latin sv tr ug uk vi zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Telepathy contact list"
+HOMEPAGE="http://community.kde.org/Real-Time_Communication_and_Collaboration"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/stable/kde-telepathy/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug semantic-desktop"
+
+DEPEND="
+ >=net-im/ktp-accounts-kcm-${PV}
+ >=net-im/ktp-common-internals-${PV}[semantic-desktop?]
+ >=net-libs/telepathy-qt-0.9.3
+ semantic-desktop? ( >=net-libs/libkpeople-0.2.1 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KPeople)
+ )
+
+ kde4-base_src_configure
+}