summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-12-07 16:30:52 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-12-07 16:30:52 +0000
commit2c7b979ce8d036b1bd11ececb164befab8a563fd (patch)
treec42deafd68b7915e578ee22030522454485e82b9 /net-im/licq
parentFixed [! -e ${ROOT}etc/localtime] && "Please..." line to have an 'echo' (diff)
downloadgentoo-2-2c7b979ce8d036b1bd11ececb164befab8a563fd.tar.gz
gentoo-2-2c7b979ce8d036b1bd11ececb164befab8a563fd.tar.bz2
gentoo-2-2c7b979ce8d036b1bd11ececb164befab8a563fd.zip
New version. Seg faults on me, so I'll package mask until I find out if it's
just my messed-up system.
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/files/digest-licq-1.0.41
-rw-r--r--net-im/licq/licq-1.0.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-im/licq/files/digest-licq-1.0.4 b/net-im/licq/files/digest-licq-1.0.4
new file mode 100644
index 000000000000..827ef1fcfd0d
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.0.4
@@ -0,0 +1 @@
+MD5 df3e50c1b03aa0cf2ecd1c27af3588e7 licq-1.0.4.tar.bz2 1720320
diff --git a/net-im/licq/licq-1.0.4.ebuild b/net-im/licq/licq-1.0.4.ebuild
new file mode 100644
index 000000000000..fa3d7fae8ccc
--- /dev/null
+++ b/net-im/licq/licq-1.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4.ebuild,v 1.1 2001/12/07 16:30:52 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="licq"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.licq.org"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-x11-2.2.1 )
+ kde? ( >=kde-base/kdebase-2.1 )"
+
+src_compile() {
+ local myconf
+ local myconf2
+
+ if [ -z "`use ssl`" ]
+ then
+ myconf="--disable-openssl"
+ fi
+
+ if [ "`use socks5`" ]
+ then
+ myconf="${myconf} --enable-socks5"
+ fi
+
+ ./configure --host=${CHOST} --prefix=/usr ${myconf} || die
+ make || die
+
+ if [ "`use qt`" ]
+ then
+ if [ "`use kde`" ]
+ then
+ myconf2="--with-kde"
+ fi
+ cd ./plugins/qt-gui-1.0.3
+ ./configure --host=${CHOST} --prefix=/usr ${myconf2} || die
+ make || die
+ cd ../..
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc README.OPENSSL doc/*
+
+ if [ "`use qt`" ]
+ then
+ cd ./plugins/qt-gui-1.0.3
+ make prefix=${D}/usr install || die
+ cd ../..
+ fi
+}
+