summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-01-03 22:23:45 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-01-03 22:23:45 +0000
commit9636ee61b31e93dfc18339cf30ab503f267f692c (patch)
tree04b0e821c75d31204dc4f1a33b9282272949eb4a /net-im/tapioca-xmpp
parentadd use-based dep for media-libs/imlib (bug #229477) (diff)
downloadgentoo-2-9636ee61b31e93dfc18339cf30ab503f267f692c.tar.gz
gentoo-2-9636ee61b31e93dfc18339cf30ab503f267f692c.tar.bz2
gentoo-2-9636ee61b31e93dfc18339cf30ab503f267f692c.zip
Add patch to fix compilation with gcc-4.3 by John Keeping <john DOT keeping AT lineone DOT net>; bug #248705
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 i686)
Diffstat (limited to 'net-im/tapioca-xmpp')
-rw-r--r--net-im/tapioca-xmpp/ChangeLog9
-rw-r--r--net-im/tapioca-xmpp/files/tapioca-xmpp-0.3.9-gcc43.patch11
-rw-r--r--net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild15
3 files changed, 30 insertions, 5 deletions
diff --git a/net-im/tapioca-xmpp/ChangeLog b/net-im/tapioca-xmpp/ChangeLog
index 0fa60fd0eefd..a54378886aa2 100644
--- a/net-im/tapioca-xmpp/ChangeLog
+++ b/net-im/tapioca-xmpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/tapioca-xmpp
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tapioca-xmpp/ChangeLog,v 1.7 2007/06/30 17:44:01 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tapioca-xmpp/ChangeLog,v 1.8 2009/01/03 22:23:45 halcy0n Exp $
+
+ 03 Jan 2009; Mark Loeser <halcy0n@gentoo.org>
+ +files/tapioca-xmpp-0.3.9-gcc43.patch, tapioca-xmpp-0.3.9.ebuild:
+ Add patch to fix compilation with gcc-4.3 by John Keeping <john DOT
+ keeping AT lineone DOT net>; bug #248705
30 Jun 2007; Piotr Jaroszyński <peper@gentoo.org>
tapioca-xmpp-0.3.9.ebuild:
diff --git a/net-im/tapioca-xmpp/files/tapioca-xmpp-0.3.9-gcc43.patch b/net-im/tapioca-xmpp/files/tapioca-xmpp-0.3.9-gcc43.patch
new file mode 100644
index 000000000000..78f8d97fd6f9
--- /dev/null
+++ b/net-im/tapioca-xmpp/files/tapioca-xmpp-0.3.9-gcc43.patch
@@ -0,0 +1,11 @@
+diff -Naur ./src/xmpp_call_session_description.h ../tapioca-xmpp-0.3.9.patched/src/xmpp_call_session_description.h
+--- ./src/xmpp_call_session_description.h 2006-06-08 20:57:24.000000000 +0100
++++ ../tapioca-xmpp-0.3.9.patched/src/xmpp_call_session_description.h 2008-11-24 23:38:27.000000000 +0000
+@@ -24,6 +24,7 @@
+ #include <talk/p2p/base/sessiondescription.h>
+
+ #include <vector>
++#include <algorithm>
+ #include <string>
+
+ class XmppCallSessionDescription : public cricket::SessionDescription {
diff --git a/net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild b/net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild
index 1a4cff329858..1a4b6a8eb55d 100644
--- a/net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild
+++ b/net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild,v 1.7 2007/06/30 17:44:01 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/tapioca-xmpp/tapioca-xmpp-0.3.9.ebuild,v 1.8 2009/01/03 22:23:45 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="Tapioca XMPP protocol"
HOMEPAGE="http://tapioca-voip.sf.net"
@@ -18,6 +20,13 @@ DEPEND="net-im/tapiocad
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
}