summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-05-25 20:03:56 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-05-25 20:03:56 +0000
commit20a14fc2be09b2789d97497ec87eb92b0097b398 (patch)
treecf2bead0e07cc21a7957f3443e0bb6d9aaaf3c26 /net-im/twinkle
parentStable on x86 wrt bug #133605. (diff)
downloadgentoo-2-20a14fc2be09b2789d97497ec87eb92b0097b398.tar.gz
gentoo-2-20a14fc2be09b2789d97497ec87eb92b0097b398.tar.bz2
gentoo-2-20a14fc2be09b2789d97497ec87eb92b0097b398.zip
version bump
(Portage version: 2.1_rc2-r2)
Diffstat (limited to 'net-im/twinkle')
-rw-r--r--net-im/twinkle/ChangeLog7
-rw-r--r--net-im/twinkle/files/digest-twinkle-0.7.13
-rw-r--r--net-im/twinkle/twinkle-0.7.1.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/net-im/twinkle/ChangeLog b/net-im/twinkle/ChangeLog
index c3d4c54d7cf2..36e222fecb0d 100644
--- a/net-im/twinkle/ChangeLog
+++ b/net-im/twinkle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/twinkle
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.13 2006/05/06 02:06:46 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.14 2006/05/25 20:03:55 dragonheart Exp $
+
+*twinkle-0.7.1 (25 May 2006)
+
+ 25 May 2006; Daniel Black <dragonheart@gentoo.org> +twinkle-0.7.1.ebuild:
+ version bump
*twinkle-0.7 (06 May 2006)
diff --git a/net-im/twinkle/files/digest-twinkle-0.7.1 b/net-im/twinkle/files/digest-twinkle-0.7.1
new file mode 100644
index 000000000000..9601a1c1e7cf
--- /dev/null
+++ b/net-im/twinkle/files/digest-twinkle-0.7.1
@@ -0,0 +1,3 @@
+MD5 5f6b909cde026182750119bf8c0bed33 twinkle-0.7.1.tar.gz 949844
+RMD160 db963f84602b5afcc699bbad3c0cb4918eae05dc twinkle-0.7.1.tar.gz 949844
+SHA256 1fc2739aa2cb098e1fed7009b9e1368fdf33637e1909dc946cc6b525c3743f39 twinkle-0.7.1.tar.gz 949844
diff --git a/net-im/twinkle/twinkle-0.7.1.ebuild b/net-im/twinkle/twinkle-0.7.1.ebuild
new file mode 100644
index 000000000000..9c8db21d150d
--- /dev/null
+++ b/net-im/twinkle/twinkle-0.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-0.7.1.ebuild,v 1.1 2006/05/25 20:03:56 dragonheart Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="a soft phone for your VOIP communcations using SIP"
+HOMEPAGE="http://www.twinklephone.com/"
+SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="arts"
+
+# Requires libqt-mt actually... Is that *always* built, or do we need to check?
+RDEPEND=">=net-libs/ccrtp-1.3.4
+ >=x11-libs/qt-3.3.4-r6
+ >=dev-cpp/commoncpp2-1.3.0
+ arts? ( kde-base/arts )
+ media-libs/libsndfile
+ media-libs/speex"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.4.1-badcflags.patch
+}
+
+src_compile() {
+ # todo speex confiugre patch for upstream
+ econf $(use_with arts) || die 'Error: conf failed'
+ emake -j1 || die "Error: emake failed!"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS NEWS README THANKS
+}