summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-01-24 08:36:55 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-01-24 08:36:55 +0000
commitfe18a510c5aa41fd32f12bcaf29f469f50e7896f (patch)
treea31af22c1648a51d1124c85662c7b56f6dc94f58 /net-im/twinkle
parentGentooify init script thanks to David B. Ferguson <david@microtask.ca> (diff)
downloadgentoo-2-fe18a510c5aa41fd32f12bcaf29f469f50e7896f.tar.gz
gentoo-2-fe18a510c5aa41fd32f12bcaf29f469f50e7896f.tar.bz2
gentoo-2-fe18a510c5aa41fd32f12bcaf29f469f50e7896f.zip
version bump
(Portage version: 2.1.2-r2)
Diffstat (limited to 'net-im/twinkle')
-rw-r--r--net-im/twinkle/ChangeLog7
-rw-r--r--net-im/twinkle/files/digest-twinkle-0.9-r21
-rw-r--r--net-im/twinkle/files/digest-twinkle-1.03
-rw-r--r--net-im/twinkle/twinkle-1.0.ebuild54
4 files changed, 64 insertions, 1 deletions
diff --git a/net-im/twinkle/ChangeLog b/net-im/twinkle/ChangeLog
index 377263915317..ee668e906dd2 100644
--- a/net-im/twinkle/ChangeLog
+++ b/net-im/twinkle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/twinkle
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.24 2007/01/06 15:47:48 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.25 2007/01/24 08:36:55 dragonheart Exp $
+
+*twinkle-1.0 (24 Jan 2007)
+
+ 24 Jan 2007; Daniel Black <dragonheart@gentoo.org> +twinkle-1.0.ebuild:
+ version bump
06 Jan 2007; Timothy Redaelli <drizzt@gentoo.org>
-files/twinkle-0.8-autoconfspeex.patch, -twinkle-0.8.ebuild,
diff --git a/net-im/twinkle/files/digest-twinkle-0.9-r2 b/net-im/twinkle/files/digest-twinkle-0.9-r2
index 46ac5b9dfe1d..0f87aa58bd88 100644
--- a/net-im/twinkle/files/digest-twinkle-0.9-r2
+++ b/net-im/twinkle/files/digest-twinkle-0.9-r2
@@ -1,2 +1,3 @@
+MD5 74ef85e9f4570cec10bd23d301f5549e twinkle-0.9.tar.gz 1012524
RMD160 f6b8b70a9630687cf7f100c9dde888289d97f082 twinkle-0.9.tar.gz 1012524
SHA256 22f536aaf6a7aa6870c31d03190b206509cfc8b6147c3af7080d6dbfa5a992b6 twinkle-0.9.tar.gz 1012524
diff --git a/net-im/twinkle/files/digest-twinkle-1.0 b/net-im/twinkle/files/digest-twinkle-1.0
new file mode 100644
index 000000000000..6d8d29a59905
--- /dev/null
+++ b/net-im/twinkle/files/digest-twinkle-1.0
@@ -0,0 +1,3 @@
+MD5 3180475a8eade9918bc1299dcbfe1fcc twinkle-1.0.tar.gz 1172116
+RMD160 9dea2207c0c421931d5190d5382dbcda321e120e twinkle-1.0.tar.gz 1172116
+SHA256 f3513deda4cf24f285d48538b2ccffca3ff2e936b942b71f30f7ac13896c58cc twinkle-1.0.tar.gz 1172116
diff --git a/net-im/twinkle/twinkle-1.0.ebuild b/net-im/twinkle/twinkle-1.0.ebuild
new file mode 100644
index 000000000000..e1e4434093e5
--- /dev/null
+++ b/net-im/twinkle/twinkle-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-1.0.ebuild,v 1.1 2007/01/24 08:36:55 dragonheart Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="a soft phone for your VOIP communcations using SIP"
+HOMEPAGE="http://www.twinklephone.com/"
+SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="arts speex ilbc zrtp"
+
+# Requires libqt-mt actually... Is that *always* built, or do we need to check?
+RDEPEND=">=net-libs/ccrtp-1.5.0
+ >=dev-cpp/commoncpp2-1.4.2
+ $(qt_min_version 3.3.0)
+ arts? ( kde-base/arts )
+ media-libs/libsndfile
+ dev-libs/boost
+ speex? ( media-libs/speex )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ zrtp? ( net-libs/libzrtpcpp )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.4.1-badcflags.patch
+}
+
+src_compile() {
+ econf \
+ $(use_with ilbc) \
+ $(use_with arts) \
+ $(use_with zrtp) \
+ $(use_with speex) || die 'Error: conf failed'
+ emake || die "Error: emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README THANKS
+ domenu twinkle.desktop
+}
+
+pkg_postinst() {
+ elog "if you get crashes on startup re-emerge commoncpp2 ccrtp and twinkle"
+ elog "see http://www.xs4all.nl/~mfnboer/twinkle/faq.html#crash_startup"
+}