summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-30 06:10:19 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-30 06:10:19 +0000
commit4dcbb85140af35c76b777081a7a3b205c4f68908 (patch)
treedc29eaccf70a781a4d0e5b19daa2692ca96a2f38 /net-im
parentadd __with_kde for naz (diff)
downloadgentoo-2-4dcbb85140af35c76b777081a7a3b205c4f68908.tar.gz
gentoo-2-4dcbb85140af35c76b777081a7a3b205c4f68908.tar.bz2
gentoo-2-4dcbb85140af35c76b777081a7a3b205c4f68908.zip
oopsies
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/licq-1.0.3-r2.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/net-im/licq/licq-1.0.3-r2.ebuild b/net-im/licq/licq-1.0.3-r2.ebuild
index 1250759ee38e..b7e3a3f34f0b 100644
--- a/net-im/licq/licq-1.0.3-r2.ebuild
+++ b/net-im/licq/licq-1.0.3-r2.ebuild
@@ -13,13 +13,10 @@ SRC_URI="http://download.sourceforge.net/${PN}/${A}
ftp://mirror.itcnet.ro/pub/${PN}/srcs/${A}"
HOMEPAGE="http://www.licq.org"
-DEPEND="virtual/glibc ssl? ( >=dev-libs/openssl-0.9.6 )
- qt? ( >=x11-libs/qt-x11-2.2.1 >=kde-base/kdebase-2.1 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-x11-2.2.1 )
+ kde? ( >=kde-base/kdebase-2.1 )"
src_compile() {
local myconf
@@ -27,20 +24,24 @@ src_compile() {
then
myconf="--disable-openssl"
fi
- if [ "`use kde`" ]
- then
- myconf="${myconf} --with-kde"
- fi
+
if [ "`use socks5`" ]
then
myconf="${myconf} --enable-socks5"
fi
+
try ./configure --host=${CHOST} --prefix=/usr ${myconf}
try make
+
if [ "`use qt`" ]
then
+ local myconf2
+ if [ "`use kde`" ]
+ then
+ myconf2="--with-kde"
+ fi
cd ./plugins/qt-gui-1.0.3
- try ./configure --host=${CHOST} --prefix=/usr
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf2}
try make
cd ../..
fi
@@ -49,6 +50,7 @@ src_compile() {
src_install() {
try make prefix=${D}/usr install
dodoc README.OPENSSL doc/*
+
if [ "`use qt`" ]
then
cd ./plugins/qt-gui-1.0.3