summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-09-18 16:15:29 +0000
committerHanno Böck <hanno@gentoo.org>2013-09-18 16:15:29 +0000
commit5e8f6db366c471b71236fabd479f9553fd296f7c (patch)
tree5f111f9f3cc4a2cbb307d4a0a2d26e38d19aad69 /net-im
parentVersion bump. (diff)
downloadgentoo-2-5e8f6db366c471b71236fabd479f9553fd296f7c.tar.gz
gentoo-2-5e8f6db366c471b71236fabd479f9553fd296f7c.tar.bz2
gentoo-2-5e8f6db366c471b71236fabd479f9553fd296f7c.zip
pyaim-t: fix deprecated PIL imports, various cleanups, new eclass
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pyaim-t/ChangeLog9
-rw-r--r--net-im/pyaim-t/files/pyaim-t-0.8-initd-r124
-rw-r--r--net-im/pyaim-t/files/pyaim-t-0.8.0.1-pillow-imaging.patch36
-rw-r--r--net-im/pyaim-t/pyaim-t-0.8.0.1-r1.ebuild51
4 files changed, 119 insertions, 1 deletions
diff --git a/net-im/pyaim-t/ChangeLog b/net-im/pyaim-t/ChangeLog
index cab511a8bc3d..74f91555754d 100644
--- a/net-im/pyaim-t/ChangeLog
+++ b/net-im/pyaim-t/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pyaim-t
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyaim-t/ChangeLog,v 1.15 2013/08/03 09:45:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyaim-t/ChangeLog,v 1.16 2013/09/18 16:15:29 hanno Exp $
+
+*pyaim-t-0.8.0.1-r1 (18 Sep 2013)
+
+ 18 Sep 2013; Hanno Boeck <hanno@gentoo.org> +pyaim-t-0.8.0.1-r1.ebuild,
+ +files/pyaim-t-0.8.0.1-pillow-imaging.patch, +files/pyaim-t-0.8-initd-r1:
+ Fix old PIL imports, move to new eclass, cleanup, fix init script pidfile dir
+ creation, sync with pyicq-t.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> pyaim-t-0.8.0.1.ebuild,
pyaim-t-0.8a.ebuild:
diff --git a/net-im/pyaim-t/files/pyaim-t-0.8-initd-r1 b/net-im/pyaim-t/files/pyaim-t-0.8-initd-r1
new file mode 100644
index 000000000000..0e555bc0901b
--- /dev/null
+++ b/net-im/pyaim-t/files/pyaim-t-0.8-initd-r1
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyaim-t/files/pyaim-t-0.8-initd-r1,v 1.1 2013/09/18 16:15:29 hanno Exp $
+
+depend() {
+ need net
+ use jabber-server
+}
+
+start() {
+ ebegin "Starting AIM Jabber Transport"
+ checkpath -q -d -m 0755 -o jabber:jabber /var/run/jabber/
+ start-stop-daemon --start --pidfile /var/run/jabber/pyaim-t.pid -u jabber -g jabber \
+ --exec INSPATH/pyaim-t.py -- \
+ -b -c /etc/jabber/pyaim-t.xml -l /var/log/jabber/pyaim-t.log
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping AIM Jabber Transport"
+ start-stop-daemon --stop --quiet --pidfile /var/run/jabber/pyaim-t.pid
+ eend $?
+}
diff --git a/net-im/pyaim-t/files/pyaim-t-0.8.0.1-pillow-imaging.patch b/net-im/pyaim-t/files/pyaim-t-0.8.0.1-pillow-imaging.patch
new file mode 100644
index 000000000000..13067925c18a
--- /dev/null
+++ b/net-im/pyaim-t/files/pyaim-t-0.8.0.1-pillow-imaging.patch
@@ -0,0 +1,36 @@
+diff -Naur pyaimt-0.8.0.1/src/contact.py pyaimt-0.8.0.1-1/src/contact.py
+--- pyaimt-0.8.0.1/src/contact.py 2009-08-24 15:04:03.000000000 +0200
++++ pyaimt-0.8.0.1-1/src/contact.py 2013-09-18 17:57:12.863780595 +0200
+@@ -13,7 +13,7 @@
+ import globals
+ import base64
+ if not config.disableAvatars:
+- import Image
++ import PIL.Image as Image
+ import StringIO
+
+
+diff -Naur pyaimt-0.8.0.1/src/imgmanip.py pyaimt-0.8.0.1-1/src/imgmanip.py
+--- pyaimt-0.8.0.1/src/imgmanip.py 2009-08-24 15:04:03.000000000 +0200
++++ pyaimt-0.8.0.1-1/src/imgmanip.py 2013-09-18 17:57:12.863780595 +0200
+@@ -5,7 +5,7 @@
+
+ if not config.disableAvatars:
+ try:
+- import Image
++ import PIL.Image as Image
+ import StringIO
+
+ def convertToPNG(imageData):
+diff -Naur pyaimt-0.8.0.1/tools/infodump.py pyaimt-0.8.0.1-1/tools/infodump.py
+--- pyaimt-0.8.0.1/tools/infodump.py 2009-08-24 15:04:03.000000000 +0200
++++ pyaimt-0.8.0.1-1/tools/infodump.py 2013-09-18 17:57:12.864780582 +0200
+@@ -41,7 +41,7 @@
+ print "Nevow Version: Unknown or Not Installed"
+
+ try:
+- from Image import VERSION
++ from PIL.Image import VERSION
+ print "Python Imaging Library (PIL) Version: " + VERSION
+ except:
+ print "Python Imaging Library (PIL) Version: Unknown or Not Installed"
diff --git a/net-im/pyaim-t/pyaim-t-0.8.0.1-r1.ebuild b/net-im/pyaim-t/pyaim-t-0.8.0.1-r1.ebuild
new file mode 100644
index 000000000000..56bc65237abd
--- /dev/null
+++ b/net-im/pyaim-t/pyaim-t-0.8.0.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyaim-t/pyaim-t-0.8.0.1-r1.ebuild,v 1.1 2013/09/18 16:15:29 hanno Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils python-single-r1
+
+MY_P="${P/pyaim-t/pyaimt}"
+DESCRIPTION="Python based jabber transport for AIM"
+HOMEPAGE="http://code.google.com/p/pyaimt/"
+SRC_URI="http://pyaimt.googlecode.com/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webinterface"
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-words[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python26-warnings.patch"
+ epatch "${FILESDIR}/${P}-pillow-imaging.patch"
+}
+
+src_install() {
+ python_moduleinto ${PN}
+ cp PyAIMt.py ${PN}.py
+ python_domodule ${PN}.py data tools src
+
+ insinto /etc/jabber
+ newins config_example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ fperms 755 "$(python_get_sitedir)/${PN}/${PN}.py"
+ sed -i \
+ -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
+ -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ "${ED}/etc/jabber/${PN}.xml"
+
+ newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
+ sed -i -e "s:INSPATH:$(python_get_sitedir)/${PN}:" "${ED}/etc/init.d/${PN}"
+ python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
+}