summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-16 09:08:16 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-16 09:08:16 +0000
commitc1d08a4b85fba05f5f7b0831e2bbb0f3e5cae3eb (patch)
tree7ada20d6fce38132acef113113df3e7d58b9ce47 /net-im
parent.packlist and *.bs files are installed to VENDOR_ARCH not VENDOR_LIB. Deletin... (diff)
downloadgentoo-2-c1d08a4b85fba05f5f7b0831e2bbb0f3e5cae3eb.tar.gz
gentoo-2-c1d08a4b85fba05f5f7b0831e2bbb0f3e5cae3eb.tar.bz2
gentoo-2-c1d08a4b85fba05f5f7b0831e2bbb0f3e5cae3eb.zip
Fix uninitialized GError*s causing tests to break, bug #323751
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/empathy/ChangeLog6
-rw-r--r--net-im/empathy/empathy-2.30.1.1.ebuild9
-rw-r--r--net-im/empathy/files/empathy-2.30.1.1-init-gerror.patch21
3 files changed, 34 insertions, 2 deletions
diff --git a/net-im/empathy/ChangeLog b/net-im/empathy/ChangeLog
index a65ae27d3664..720dbfb5f288 100644
--- a/net-im/empathy/ChangeLog
+++ b/net-im/empathy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/empathy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/ChangeLog,v 1.55 2010/06/14 15:33:42 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/ChangeLog,v 1.56 2010/06/16 09:08:16 pacho Exp $
+
+ 16 Jun 2010; Pacho Ramos <pacho@gentoo.org> empathy-2.30.1.1.ebuild,
+ +files/empathy-2.30.1.1-init-gerror.patch:
+ Fix uninitialized GError*s causing tests to break, bug #323751
14 Jun 2010; Olivier Crête <tester@gentoo.org> empathy-2.30.1.1.ebuild:
Older libunique prevent empathy from compiling, bug #323905
diff --git a/net-im/empathy/empathy-2.30.1.1.ebuild b/net-im/empathy/empathy-2.30.1.1.ebuild
index 578c03a94c4b..9cd86886ea9f 100644
--- a/net-im/empathy/empathy-2.30.1.1.ebuild
+++ b/net-im/empathy/empathy-2.30.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/empathy-2.30.1.1.ebuild,v 1.2 2010/06/14 15:33:42 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/empathy-2.30.1.1.ebuild,v 1.3 2010/06/16 09:08:16 pacho Exp $
EAPI="2"
@@ -79,6 +79,13 @@ pkg_setup() {
$(use_enable webkit)"
}
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix uninitialized GError*s causing tests to break, bug #323751
+ epatch "${FILESDIR}/${P}-init-gerror.patch"
+}
+
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
emake check || die "emake check failed."
diff --git a/net-im/empathy/files/empathy-2.30.1.1-init-gerror.patch b/net-im/empathy/files/empathy-2.30.1.1-init-gerror.patch
new file mode 100644
index 000000000000..aba40ac31949
--- /dev/null
+++ b/net-im/empathy/files/empathy-2.30.1.1-init-gerror.patch
@@ -0,0 +1,21 @@
+From 9783f0a3cf1449e2566de295b2ffa1ad17519fdc Mon Sep 17 00:00:00 2001
+From: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
+Date: Tue, 15 Jun 2010 11:17:09 +0000
+Subject: init GError so 'make check' will be happy (#621409)
+
+---
+diff --git a/libempathy/empathy-dispatcher.c b/libempathy/empathy-dispatcher.c
+index c5908a8..f616a99 100644
+--- a/libempathy/empathy-dispatcher.c
++++ b/libempathy/empathy-dispatcher.c
+@@ -344,7 +344,7 @@ dispatcher_connection_invalidated_cb (TpConnection *connection,
+ if (connection_data != NULL)
+ {
+ GList *l;
+- GError *error;
++ GError *error = NULL;
+
+ error = g_error_new_literal (domain, code, message);
+
+--
+cgit v0.8.3.1