summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-26 23:44:03 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-26 23:44:03 +0000
commitd72d10b04d9eda11817cc5d24bfea7a72bfec58f (patch)
treeec7e0dfb9d27f9d74c3c87be641b3715d216c42e /net-im
parentRevbump. Use EAPI=2 and use dependencies. (diff)
downloadgentoo-2-d72d10b04d9eda11817cc5d24bfea7a72bfec58f.tar.gz
gentoo-2-d72d10b04d9eda11817cc5d24bfea7a72bfec58f.tar.bz2
gentoo-2-d72d10b04d9eda11817cc5d24bfea7a72bfec58f.zip
Revbump. Use EAPI=2 and use dependencies.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/msnlib/ChangeLog7
-rw-r--r--net-im/msnlib/msnlib-3.6-r1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-im/msnlib/ChangeLog b/net-im/msnlib/ChangeLog
index 7833951598a2..3cbdc4bba430 100644
--- a/net-im/msnlib/ChangeLog
+++ b/net-im/msnlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/msnlib
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/msnlib/ChangeLog,v 1.22 2008/05/29 14:13:51 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/msnlib/ChangeLog,v 1.23 2008/10/26 23:44:03 hawking Exp $
+
+*msnlib-3.6-r1 (26 Oct 2008)
+
+ 26 Oct 2008; Ali Polatel <hawking@gentoo.org> +msnlib-3.6-r1.ebuild:
+ Revbump. Use EAPI=2 and use dependencies.
29 May 2008; Ali Polatel <hawking@gentoo.org> msnlib-3.6.ebuild:
python_mod_compile is ROOT aware and can take multiple file arguments.
diff --git a/net-im/msnlib/msnlib-3.6-r1.ebuild b/net-im/msnlib/msnlib-3.6-r1.ebuild
new file mode 100644
index 000000000000..532d163d7cd7
--- /dev/null
+++ b/net-im/msnlib/msnlib-3.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/msnlib/msnlib-3.6-r1.ebuild,v 1.1 2008/10/26 23:44:03 hawking Exp $
+
+EAPI="2"
+inherit python multilib distutils
+
+DESCRIPTION="A Python MSN messenger protocol library and client"
+HOMEPAGE="http://auriga.wearlab.de/~alb/msnlib/"
+SRC_URI="http://auriga.wearlab.de/~alb/msnlib/files/${PV}/${P}.tar.bz2"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="tk"
+
+DEPEND=">=dev-lang/python-2.2.2[tk?]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils_src_install
+
+ dodoc doc/* || die "dodoc failed."
+ dobin msn
+ dobin msnsetup
+ use tk && dobin utils/msntk
+
+ insinto /usr/share/doc/${PF}
+ doins msnrc.sample
+}
+
+pkg_postinst() {
+ local module
+ python_version
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/msn{cb,lib}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}