summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-04-22 13:01:56 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-04-22 13:01:56 +0000
commitefedf2ce6e65239b8086accb39dccce9bdf3b0df (patch)
treeba9f4c835855714a62ca9aa8b1dc0234588ed049 /net-im
parentbump will fix resolve in OertlichesFonbook (diff)
downloadgentoo-2-efedf2ce6e65239b8086accb39dccce9bdf3b0df.tar.gz
gentoo-2-efedf2ce6e65239b8086accb39dccce9bdf3b0df.tar.bz2
gentoo-2-efedf2ce6e65239b8086accb39dccce9bdf3b0df.zip
Bump LeechCraft to 0.5.65, thanks to 0xd34df00d
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/leechcraft-azoth/ChangeLog8
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-0.5.65.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/net-im/leechcraft-azoth/ChangeLog b/net-im/leechcraft-azoth/ChangeLog
index ff5f24a84c67..5fbe692562cb 100644
--- a/net-im/leechcraft-azoth/ChangeLog
+++ b/net-im/leechcraft-azoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/leechcraft-azoth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.18 2012/04/07 17:14:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.19 2012/04/22 13:01:56 maksbotan Exp $
+
+*leechcraft-azoth-0.5.65 (22 Apr 2012)
+
+ 22 Apr 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-azoth-0.5.65.ebuild:
+ Bump net-im/leechcraft-azoth to 0.5.65, thanks to 0xd34df00d
07 Apr 2012; Markus Meier <maekke@gentoo.org> leechcraft-azoth-0.4.99.ebuild:
x86 stable, bug #400605
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-0.5.65.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-0.5.65.ebuild
new file mode 100644
index 000000000000..68a976f4c37a
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-0.5.65.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-0.5.65.ebuild,v 1.1 2012/04/22 13:01:56 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug astrality +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+ +depester +embedmedia +herbicide +hili +isterique +juick +keeso +lastseen
+ +metacontacts +modnok +nativeemoticons +otroid +p100q +rosenthal
+ +standardstyles +xoox +xtazy +zheet"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ x11-libs/qt-webkit
+ x11-libs/qt-multimedia
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ xoox? ( >=net-libs/qxmpp-0.3.47[extras] media-libs/speex )
+ xtazy? ( x11-libs/qt-dbus )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )
+ zheet? ( net-libs/libmsn )"
+RDEPEND="${DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ modnok? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable modnok AZOTH_MODNOK)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable rosenthal AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xoox AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ $(cmake-utils_use_enable zheet AZOTH_ZHEET)"
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use rosenthal; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}