summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-12 21:06:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-12 21:06:35 +0000
commitfd316858bb89ca2b464b05b1b3708693af29c2ec (patch)
tree3d331e142f7fb57d64223f934bbbf39601e70e7e /net-im
parentFix incorrect path bug only hit building on multilib systems. See bug #140153. (diff)
downloadgentoo-2-fd316858bb89ca2b464b05b1b3708693af29c2ec.tar.gz
gentoo-2-fd316858bb89ca2b464b05b1b3708693af29c2ec.tar.bz2
gentoo-2-fd316858bb89ca2b464b05b1b3708693af29c2ec.zip
Add a few more useflags and use debug useflag to control testbed protocol.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kopete/ChangeLog6
-rw-r--r--net-im/kopete/kopete-0.12.0-r2.ebuild20
2 files changed, 22 insertions, 4 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index b6aa18e50726..8c16f9d8f4d7 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for net-im/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.68 2006/07/12 09:09:06 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.69 2006/07/12 21:06:35 flameeyes Exp $
12 Jul 2006; Markus Rothe <corsair@gentoo.org> kopete-0.12.0-r2.ebuild:
Added ~ppc64
+ 12 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ kopete-0.12.0-r2.ebuild:
+ Add a few more useflags and use debug useflag to control testbed protocol.
+
*kopete-0.12.0-r2 (11 Jul 2006)
11 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
diff --git a/net-im/kopete/kopete-0.12.0-r2.ebuild b/net-im/kopete/kopete-0.12.0-r2.ebuild
index bdf7b33988d1..2d202a8a7f78 100644
--- a/net-im/kopete/kopete-0.12.0-r2.ebuild
+++ b/net-im/kopete/kopete-0.12.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12.0-r2.ebuild,v 1.2 2006/07/12 09:09:06 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12.0-r2.ebuild,v 1.3 2006/07/12 21:06:35 flameeyes Exp $
inherit kde eutils
@@ -13,7 +13,9 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="jingle sametime ssl xmms xscreensaver slp kernel_linux latex crypt
- winpopup sms irc yahoo gadu groupwise netmeeting statistics"
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
@@ -89,6 +91,17 @@ src_unpack() {
use crypt || kopete_disable plugin cryptography
use netmeeting || kopete_disable plugin netmeeting
use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
use winpopup || kopete_disable protocol winpopup
use gadu || kopete_disable protocol '\$(GADU)'
@@ -106,7 +119,8 @@ src_compile() {
local myconf="$(use_enable jingle)
$(use_enable sametime sametime-plugin)
$(use_with xmms) --without-external-libgadu
- $(use_with xscreensaver) $(use_enable sms smsgsm)"
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
kde_src_compile
}