summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-10-10 18:07:36 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-10-10 18:07:36 +0000
commit73a5f433c0bab919db17883b38bad327875f35a9 (patch)
tree8f6fbf5e9540d7a127b24bc1e70791a0c612656e /net-irc/anope
parentFix openmotif dependency. Change EAPI to 1. (diff)
downloadgentoo-2-73a5f433c0bab919db17883b38bad327875f35a9.tar.gz
gentoo-2-73a5f433c0bab919db17883b38bad327875f35a9.tar.bz2
gentoo-2-73a5f433c0bab919db17883b38bad327875f35a9.zip
Bumping to 1.8.5
(Portage version: 2.2_rc91/cvs/Linux i686)
Diffstat (limited to 'net-irc/anope')
-rw-r--r--net-irc/anope/ChangeLog10
-rw-r--r--net-irc/anope/anope-1.8.0.ebuild159
-rw-r--r--net-irc/anope/anope-1.8.0_rc1.ebuild159
-rw-r--r--net-irc/anope/anope-1.8.5.ebuild (renamed from net-irc/anope/anope-1.8.4.ebuild)16
-rw-r--r--net-irc/anope/files/ldflags-fix.patch36
5 files changed, 52 insertions, 328 deletions
diff --git a/net-irc/anope/ChangeLog b/net-irc/anope/ChangeLog
index 75cb637ad3d3..2d875eddb497 100644
--- a/net-irc/anope/ChangeLog
+++ b/net-irc/anope/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/anope
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.16 2010/07/22 11:43:47 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.17 2010/10/10 18:07:36 gurligebis Exp $
+
+*anope-1.8.5 (10 Oct 2010)
+
+ 10 Oct 2010; <gurligebis@gentoo.org> -anope-1.8.0_rc1.ebuild,
+ -anope-1.8.0.ebuild, -anope-1.8.4.ebuild, +anope-1.8.5.ebuild,
+ +files/ldflags-fix.patch:
+ Bumping to 1.8.5, removing old versions and fixing LDFLAGS problem
+ wrt. bug #339747 .
*anope-1.8.4 (22 Jul 2010)
diff --git a/net-irc/anope/anope-1.8.0.ebuild b/net-irc/anope/anope-1.8.0.ebuild
deleted file mode 100644
index 9657068dbcd1..000000000000
--- a/net-irc/anope/anope-1.8.0.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.0.ebuild,v 1.1 2009/06/27 11:04:34 patrick Exp $
-
-inherit eutils versionator
-
-MY_PV=$(replace_version_separator 3 '-')
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DESCRIPTION="Anope IRC Services"
-HOMEPAGE="http://www.anope.org"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="mysql"
-
-DEPEND="mysql? ( virtual/mysql )"
-
-INSTALL_DIR="/opt/anope"
-
-pkg_setup() {
- enewgroup anope
- enewuser anope -1 -1 "${INSTALL_DIR}" anope
- if has_version net-irc/anope ; then
- ewarn
- ewarn "Make backups before updating as they will be overwritten"
- ewarn
- ebeep 10
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/pid-patch.diff
-}
-
-src_compile() {
- local myconf
- if ! use mysql; then
- myconf="${myconf} --without-mysql"
- fi
-
- econf \
- ${myconf} \
- --bindir ${INSTALL_DIR} \
- --with-bindir=${INSTALL_DIR} \
- --with-datadir=${INSTALL_DIR}/data \
- --with-modules=${INSTALL_DIR}/modules \
- --with-encryption \
- --with-rungroup=anope \
- --with-permissions=077 \
- || die "Configuration failed."
-
- sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
-
- emake || die "Make failed."
-}
-
-src_install() {
- dodir ${INSTALL_DIR}
- dodir ${INSTALL_DIR}/data
- dodir ${INSTALL_DIR}/data/logs
- dodir ${INSTALL_DIR}/data/languages
- dodir ${INSTALL_DIR}/data/modules
- dodir ${INSTALL_DIR}/data/modules/runtime
- dodir ${INSTALL_DIR}/modules
-
- dodir /var/run/anope
- fowners anope:anope /var/run/anope
- keepdir /var/run/anope
-
- fowners anope:anope ${INSTALL_DIR}
- fowners anope:anope ${INSTALL_DIR}/data
- fowners anope:anope ${INSTALL_DIR}/data/logs
- fowners anope:anope ${INSTALL_DIR}/data/languages
- fowners anope:anope ${INSTALL_DIR}/data/modules
- fowners anope:anope ${INSTALL_DIR}/data/modules/runtime
- fowners anope:anope ${INSTALL_DIR}/modules
-
- exeinto ${INSTALL_DIR}
- doexe src/services
- insinto ${INSTALL_DIR}/data
- newins data/example.conf services.conf.example
-
- newinitd "${FILESDIR}"/anope.initd anope
- newconfd "${FILESDIR}"/anope.confd anope
-
- insinto ${INSTALL_DIR}/modules
- doins src/modules/*.so
-
- keepdir ${INSTALL_DIR}/data/logs
-
- insinto ${INSTALL_DIR}/data/languages
- doins lang/cat
- doins lang/de
- doins lang/en_us
- doins lang/es
- doins lang/fr
- doins lang/gr
- doins lang/hun
- doins lang/it
- doins lang/nl
- doins lang/pl
- doins lang/pt
- doins lang/ru
- doins lang/tr
-
- keepdir ${INSTALL_DIR}/data/modules/runtime
-
- insinto ${INSTALL_DIR}/data/modules
- doins src/protocol/*.so
- doins src/core/*.so
-
- fowners anope:anope ${INSTALL_DIR}/services
- fowners anope:anope ${INSTALL_DIR}/data/languages/cat
- fowners anope:anope ${INSTALL_DIR}/data/languages/de
- fowners anope:anope ${INSTALL_DIR}/data/languages/en_us
- fowners anope:anope ${INSTALL_DIR}/data/languages/fr
- fowners anope:anope ${INSTALL_DIR}/data/languages/gr
- fowners anope:anope ${INSTALL_DIR}/data/languages/hun
- fowners anope:anope ${INSTALL_DIR}/data/languages/it
- fowners anope:anope ${INSTALL_DIR}/data/languages/nl
- fowners anope:anope ${INSTALL_DIR}/data/languages/pl
- fowners anope:anope ${INSTALL_DIR}/data/languages/pt
- fowners anope:anope ${INSTALL_DIR}/data/languages/ru
- fowners anope:anope ${INSTALL_DIR}/data/languages/tr
-
- dodoc Changes Changes.conf Changes.lang Changes.mysql docs/*
-
- use mysql && dodoc data/tables.sql
-}
-
-pkg_preinst() {
- if has_version net-irc/anope ; then
- elog "Making a backup of your config to data/pre-update"
- mkdir "${ROOT}"opt/anope/data/pre-update
- cp "${ROOT}"opt/anope/data/* "${ROOT}"opt/anope/data/pre-update
- fi
-}
-
-pkg_postinst() {
- echo
- ewarn "Anope won't run out of the box, you still have to configure it to match your IRCDs configuration."
- ewarn "Edit ${INSTALL_DIR}/data/services.conf to configure Anope."
- echo
- ewarn "!!! ATTENTION !!!"
- ewarn "Be sure to read Changes.mysql to update your MySQL"
- ewarn "tables or anope will break after restart"
- ewarn "!!! ATTENTION !!!"
-
- if use mysql; then
- einfo "The mysql script for updating the tables is located in the"
- einfo "/usr/share/doc/${P} directory"
- fi
-}
diff --git a/net-irc/anope/anope-1.8.0_rc1.ebuild b/net-irc/anope/anope-1.8.0_rc1.ebuild
deleted file mode 100644
index befef610afc7..000000000000
--- a/net-irc/anope/anope-1.8.0_rc1.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.0_rc1.ebuild,v 1.2 2009/01/04 21:23:25 gurligebis Exp $
-
-inherit eutils versionator
-
-MY_PV=$(replace_version_separator 3 '-')
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DESCRIPTION="Anope IRC Services"
-HOMEPAGE="http://www.anope.org"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="mysql"
-
-DEPEND="mysql? ( virtual/mysql )"
-
-INSTALL_DIR="/opt/anope"
-
-pkg_setup() {
- enewgroup anope
- enewuser anope -1 -1 "${INSTALL_DIR}" anope
- if has_version net-irc/anope ; then
- ewarn
- ewarn "Make backups before updating as they will be overwritten"
- ewarn
- ebeep 10
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/pid-patch.diff
-}
-
-src_compile() {
- local myconf
- if ! use mysql; then
- myconf="${myconf} --without-mysql"
- fi
-
- econf \
- ${myconf} \
- --bindir ${INSTALL_DIR} \
- --with-bindir=${INSTALL_DIR} \
- --with-datadir=${INSTALL_DIR}/data \
- --with-modules=${INSTALL_DIR}/modules \
- --with-encryption \
- --with-rungroup=anope \
- --with-permissions=077 \
- || die "Configuration failed."
-
- sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
-
- emake || die "Make failed."
-}
-
-src_install() {
- dodir ${INSTALL_DIR}
- dodir ${INSTALL_DIR}/data
- dodir ${INSTALL_DIR}/data/logs
- dodir ${INSTALL_DIR}/data/languages
- dodir ${INSTALL_DIR}/data/modules
- dodir ${INSTALL_DIR}/data/modules/runtime
- dodir ${INSTALL_DIR}/modules
-
- dodir /var/run/anope
- fowners anope:anope /var/run/anope
- keepdir /var/run/anope
-
- fowners anope:anope ${INSTALL_DIR}
- fowners anope:anope ${INSTALL_DIR}/data
- fowners anope:anope ${INSTALL_DIR}/data/logs
- fowners anope:anope ${INSTALL_DIR}/data/languages
- fowners anope:anope ${INSTALL_DIR}/data/modules
- fowners anope:anope ${INSTALL_DIR}/data/modules/runtime
- fowners anope:anope ${INSTALL_DIR}/modules
-
- exeinto ${INSTALL_DIR}
- doexe src/services
- insinto ${INSTALL_DIR}/data
- newins data/example.conf services.conf.example
-
- newinitd "${FILESDIR}"/anope.initd anope
- newconfd "${FILESDIR}"/anope.confd anope
-
- insinto ${INSTALL_DIR}/modules
- doins src/modules/*.so
-
- keepdir ${INSTALL_DIR}/data/logs
-
- insinto ${INSTALL_DIR}/data/languages
- doins lang/cat
- doins lang/de
- doins lang/en_us
- doins lang/es
- doins lang/fr
- doins lang/gr
- doins lang/hun
- doins lang/it
- doins lang/nl
- doins lang/pl
- doins lang/pt
- doins lang/ru
- doins lang/tr
-
- keepdir ${INSTALL_DIR}/data/modules/runtime
-
- insinto ${INSTALL_DIR}/data/modules
- doins src/protocol/*.so
- doins src/core/*.so
-
- fowners anope:anope ${INSTALL_DIR}/services
- fowners anope:anope ${INSTALL_DIR}/data/languages/cat
- fowners anope:anope ${INSTALL_DIR}/data/languages/de
- fowners anope:anope ${INSTALL_DIR}/data/languages/en_us
- fowners anope:anope ${INSTALL_DIR}/data/languages/fr
- fowners anope:anope ${INSTALL_DIR}/data/languages/gr
- fowners anope:anope ${INSTALL_DIR}/data/languages/hun
- fowners anope:anope ${INSTALL_DIR}/data/languages/it
- fowners anope:anope ${INSTALL_DIR}/data/languages/nl
- fowners anope:anope ${INSTALL_DIR}/data/languages/pl
- fowners anope:anope ${INSTALL_DIR}/data/languages/pt
- fowners anope:anope ${INSTALL_DIR}/data/languages/ru
- fowners anope:anope ${INSTALL_DIR}/data/languages/tr
-
- dodoc Changes Changes.conf Changes.lang Changes.mysql docs/*
-
- use mysql && dodoc data/tables.sql
-}
-
-pkg_preinst() {
- if has_version net-irc/anope ; then
- elog "Making a backup of your config to data/pre-update"
- mkdir "${ROOT}"opt/anope/data/pre-update
- cp "${ROOT}"opt/anope/data/* "${ROOT}"opt/anope/data/pre-update
- fi
-}
-
-pkg_postinst() {
- echo
- ewarn "Anope won't run out of the box, you still have to configure it to match your IRCDs configuration."
- ewarn "Edit ${INSTALL_DIR}/data/services.conf to configure Anope."
- echo
- ewarn "!!! ATTENTION !!!"
- ewarn "Be sure to read Changes.mysql to update your MySQL"
- ewarn "tables or anope will break after restart"
- ewarn "!!! ATTENTION !!!"
-
- if use mysql; then
- einfo "The mysql script for updating the tables is located in the"
- einfo "/usr/share/doc/${P} directory"
- fi
-}
diff --git a/net-irc/anope/anope-1.8.4.ebuild b/net-irc/anope/anope-1.8.5.ebuild
index 3d36e405ea20..dc43e525afa6 100644
--- a/net-irc/anope/anope-1.8.4.ebuild
+++ b/net-irc/anope/anope-1.8.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.4.ebuild,v 1.1 2010/07/22 11:43:47 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.5.ebuild,v 1.1 2010/10/10 18:07:36 gurligebis Exp $
+
+EAPI="2"
inherit eutils versionator
@@ -31,14 +33,12 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/pid-patch.diff
+src_prepare() {
+ epatch "${FILESDIR}/pid-patch.diff"
+ epatch "${FILESDIR}/ldflags-fix.patch"
}
-src_compile() {
+src_configure() {
local myconf
if ! use mysql; then
myconf="${myconf} --without-mysql"
@@ -56,8 +56,6 @@ src_compile() {
|| die "Configuration failed."
sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
-
- emake || die "Make failed."
}
src_install() {
diff --git a/net-irc/anope/files/ldflags-fix.patch b/net-irc/anope/files/ldflags-fix.patch
new file mode 100644
index 000000000000..253f0973591b
--- /dev/null
+++ b/net-irc/anope/files/ldflags-fix.patch
@@ -0,0 +1,36 @@
+diff -aurp a/src/core/Makefile b/src/core/Makefile
+--- a/src/core/Makefile 2010-10-10 19:55:31.396999906 +0000
++++ b/src/core/Makefile 2010-10-10 19:53:54.877001245 +0000
+@@ -24,7 +24,7 @@ distclean: spotless
+ $(CC) ${CFLAGS} ${CDEFS} ${MODULEFLAGS} -I../${INCLUDEDIR} -c $<
+
+ .o.s:
+- $(CC) ${SHARED} ../mod_version.o $< -o $*.so ${PROFILE}
++ $(CC) ${LDFLAGS} ${SHARED} ../mod_version.o $< -o $*.so ${PROFILE}
+ @$(TOUCH) $*.s
+
+ subs:
+diff -aurp a/src/modules/Makefile b/src/modules/Makefile
+--- a/src/modules/Makefile 2010-10-10 19:55:32.486000023 +0000
++++ b/src/modules/Makefile 2010-10-10 19:54:07.240000026 +0000
+@@ -27,7 +27,7 @@ distclean: spotless
+ $(CC) ${CFLAGS} ${CDEFS} ${MODULEFLAGS} -I../${INCLUDEDIR} -c $<
+
+ .o.s:
+- $(CC) ${SHARED} ../mod_version.o $< -o $*.so ${PROFILE}
++ $(CC) ${LDFLAGS} ${SHARED} ../mod_version.o $< -o $*.so ${PROFILE}
+ @$(TOUCH) $*.s
+
+ subs:
+diff -aurp a/src/protocol/Makefile b/src/protocol/Makefile
+--- a/src/protocol/Makefile 2010-10-10 19:55:33.605002302 +0000
++++ b/src/protocol/Makefile 2010-10-10 19:54:19.271997806 +0000
+@@ -24,7 +24,7 @@ distclean: clean spotless
+ $(CC) ${CFLAGS} ${CDEFS} ${MODULEFLAGS} -I../${INCLUDEDIR} -c $<
+
+ .o.s:
+- $(CC) ${SHARED} ../mod_version.o $< -o $*.so ${PROFILE}
++ $(CC) ${LDFLAGS} ${SHARED} ../mod_version.o $< -o $*.so ${PROFILE}
+ @$(TOUCH) $*.s
+
+ subs: