summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-03 18:08:21 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-03 18:08:21 +0000
commit345a3e5b777cadd35180042fd314e585964c3fa7 (patch)
treec41742612fcf335865610521469edf851cf84b78 /net-irc/bitchx
parentfix the fix.. duh (diff)
downloadgentoo-2-345a3e5b777cadd35180042fd314e585964c3fa7.tar.gz
gentoo-2-345a3e5b777cadd35180042fd314e585964c3fa7.tar.bz2
gentoo-2-345a3e5b777cadd35180042fd314e585964c3fa7.zip
touchups
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/bitchx-1.0.19-r6.ebuild67
1 files changed, 26 insertions, 41 deletions
diff --git a/net-irc/bitchx/bitchx-1.0.19-r6.ebuild b/net-irc/bitchx/bitchx-1.0.19-r6.ebuild
index 8fa892c8f41c..e81840de167e 100644
--- a/net-irc/bitchx/bitchx-1.0.19-r6.ebuild
+++ b/net-irc/bitchx/bitchx-1.0.19-r6.ebuild
@@ -1,29 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.19-r6.ebuild,v 1.3 2003/09/06 22:02:56 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.19-r6.ebuild,v 1.4 2003/10/03 18:08:21 vapier Exp $
inherit flag-o-matic eutils
-IUSE="ssl esd gnome xmms ncurses ipv6 gtk cjk"
-
MY_P=ircii-pana-${PV/.0./.0c}
S=${WORKDIR}/BitchX
DESCRIPTION="An IRC Client"
-SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz"
HOMEPAGE="http://www.bitchx.com/"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
-
-replace-flags -O[3-9] -O2
-
-# BitchX needs to be merged with -fPIC on alpha boxes
-# This fixes bug 10932
-[ "${ARCH}" = "alpha" ] && append-flags "-fPIC"
-
-# hppa need -fPIC too
-[ "${ARCH}" = "hppa" ] && append-flags "-fPIC"
+IUSE="ssl esd gnome xmms ncurses ipv6 gtk cjk"
DEPEND=">=sys-libs/ncurses-5.1
ssl? ( >=dev-libs/openssl-0.9.6 )
@@ -41,14 +31,19 @@ src_unpack() {
use cjk && epatch ${FILESDIR}/${P}-cjk.patch
epatch ${FILESDIR}/${P}-gcc-3.3.patch
- epatch ${FILESDIR}/${P}-security.patch || die
- epatch ${FILESDIR}/${P}-security2.patch || die
- epatch ${FILESDIR}/${P}-hebrew.patch || die
- epatch ${FILESDIR}/${P}-nickcomp-nocolor.patch || die
- epatch ${FILESDIR}/${P}-freenode.patch || die
+ epatch ${FILESDIR}/${P}-security.patch
+ epatch ${FILESDIR}/${P}-security2.patch
+ epatch ${FILESDIR}/${P}-hebrew.patch
+ epatch ${FILESDIR}/${P}-nickcomp-nocolor.patch
+ epatch ${FILESDIR}/${P}-freenode.patch
}
src_compile() {
+ # BitchX needs to be merged with -fPIC on alpha/hppa boxes #10932
+ [ "${ARCH}" == "alpha" ] && append-flags "-fPIC"
+ [ "${ARCH}" == "hppa" ] && append-flags "-fPIC"
+ replace-flags -O[3-9] -O2
+
local myconf
if [ "${DEBUG}" ]
@@ -57,10 +52,6 @@ src_compile() {
myconf="${myconf} --enable-debug"
fi
- use ssl \
- && myconf="${myconf} --with-ssl" \
- || myconf="${myconf} --without-ssl"
-
use esd && use gtk \
&& myconf="${myconf} --enable-sound" \
|| myconf="${myconf} --disable-sound"
@@ -69,10 +60,6 @@ src_compile() {
&& myconf="${myconf} --with-gtk" \
|| myconf="${myconf} --without-gtk"
- use ipv6 \
- && myconf="${myconf} --enable-ipv6" \
- || myconf="${myconf} --disable-ipv6"
-
#not tested
#use ncurses \
# && myconf="${myconf} --without-tgetent" \
@@ -94,18 +81,20 @@ src_compile() {
einfo "gtkBitchX will be built, if you want BitchX please issue"
einfo "USE="-gtk" emerge bitchx"
sleep 10
- ) && CFLAGS="${CFLAGS} -I/usr/include/gnome-1.0"
+ ) && append-flags -I/usr/include/gnome-1.0
- econf CFLAGS="${CFLAGS}" \
+ econf \
+ CFLAGS="${CFLAGS}" \
--enable-cdrom \
--with-plugins \
+ `use_with ssl` \
+ `use_enable ipv6` \
${myconf} || die
emake || die
cd contrib && make vh1
}
-src_install () {
-
+src_instal () {
einstall || die
[ -f contrib/vh1 ] && cp contrib/vh1 ${D}/usr/bin/
rm ${D}/usr/share/man/man1/BitchX*
@@ -113,12 +102,12 @@ src_install () {
use gnome && use gtk && ( \
exeinto /usr/bin
- # newexe ${S}/source/BitchX BitchX-1.0c19
+ #newexe ${S}/source/BitchX BitchX-1.0c19
dosym gtkBitchX-1.0c19 /usr/bin/gtkBitchX
einfo "Installed gtkBitchX"
) || dosym BitchX-1.0c19 /usr/bin/BitchX
- chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+ fperms a-x /usr/lib/bx/plugins/BitchX.hints
cd ${S}
dodoc Changelog README* IPv6-support COPYING
@@ -136,13 +125,9 @@ src_install () {
cd ../dll
insinto /usr/lib/bx/wav
doins wavplay/*.wav
- cp acro/README acro/README.acro
- dodoc acro/README.acro
- cp arcfour/README arcfour/README.arcfour
- dodoc arcfour/README.arcfour
- cp blowfish/README blowfish/README.blowfish
- dodoc blowfish/README.blowfish
dodoc nap/README.nap
- cp qbx/README qbx/README.qbx
- dodoc qbx/README.qbx
+ newdoc acro/README README.acro
+ newdoc arcfour/README README.arcfour
+ newdoc blowfish/README README.blowfish
+ newdoc qbx/README README.qbx
}