summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-10-20 15:20:01 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-10-20 15:20:01 +0000
commit35e385460db4381d0a5be66f7649eaa300ed7be8 (patch)
tree701ce850bdcbd896e7d0b9145bb04c8afb35f01e /net-irc/charybdis
parentMark ~amd64-linux (diff)
downloadgentoo-2-35e385460db4381d0a5be66f7649eaa300ed7be8.tar.gz
gentoo-2-35e385460db4381d0a5be66f7649eaa300ed7be8.tar.bz2
gentoo-2-35e385460db4381d0a5be66f7649eaa300ed7be8.zip
Version bump
(Portage version: 2.2.0_alpha141/cvs/Linux i686, signed Manifest commit with key 23E9E900)
Diffstat (limited to 'net-irc/charybdis')
-rw-r--r--net-irc/charybdis/ChangeLog9
-rw-r--r--net-irc/charybdis/charybdis-3.4.0.ebuild93
-rw-r--r--net-irc/charybdis/files/charybdis-3.4.0-testline-crash-fix.patch20
3 files changed, 120 insertions, 2 deletions
diff --git a/net-irc/charybdis/ChangeLog b/net-irc/charybdis/ChangeLog
index f3276fa177ef..adaecb48d020 100644
--- a/net-irc/charybdis/ChangeLog
+++ b/net-irc/charybdis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/charybdis
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/ChangeLog,v 1.15 2012/04/05 20:36:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/ChangeLog,v 1.16 2012/10/20 15:20:01 jdhore Exp $
+
+*charybdis-3.4.0 (20 Oct 2012)
+
+ 20 Oct 2012; Jeff Horelick <jdhore@gentoo.org> +charybdis-3.4.0.ebuild,
+ +files/charybdis-3.4.0-testline-crash-fix.patch:
+ Version bump
05 Apr 2012; Jeff Horelick <jdhore@gentoo.org> charybdis-3.3.0.ebuild:
marked x86 per bug 410847
@@ -17,4 +23,3 @@
+files/charybdis.confd, +files/charybdis.initd, +metadata.xml:
Add net-irc/charybdis-3.3.0, a ratbox-based IRCd from atheme, for bug
#340611.
-
diff --git a/net-irc/charybdis/charybdis-3.4.0.ebuild b/net-irc/charybdis/charybdis-3.4.0.ebuild
new file mode 100644
index 000000000000..dcdbce37fa4d
--- /dev/null
+++ b/net-irc/charybdis/charybdis-3.4.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/charybdis/charybdis-3.4.0.ebuild,v 1.1 2012/10/20 15:20:01 jdhore Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib user
+
+DESCRIPTION="The atheme project's IRCd based on ratbox"
+HOMEPAGE="http://atheme.org/project/charybdis http://www.stack.nl/~jilles/irc/#charybdis"
+SRC_URI="http://www.stack.nl/~jilles/irc/${P}.tbz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +ipv6 largenet ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-testline-crash-fix.patch
+ eautoreconf
+
+ # Fill the example configuration file with proper paths.
+ sed -i \
+ -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
+ -e "s:etc/:../etc/${PN}/:g" \
+ -e "s:logs/:../var/log/charybdis/:g" \
+ -e "s:test\.\(cert\|key\):ssl.\1:g" \
+ doc/example.conf \
+ doc/reference.conf \
+ || die
+}
+
+src_configure() {
+ econf \
+ ac_cv_prog_cc_g=no \
+ --disable-gnutls \
+ $(use_enable debug assert soft) \
+ $(use_enable debug iodebug) \
+ $(use_enable ipv6) \
+ $(use_enable !largenet small-net) \
+ $(use_enable ssl openssl) \
+ $(use_enable zlib) \
+ --with-program-prefix=charybdis- \
+ \
+ --enable-fhs-paths \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
+ --with-logdir="${EPREFIX}"/var/log/${PN} \
+ --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+ --with-rundir="${EPREFIX}"/var/run
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto etc/${PN}
+ newins doc/reference.conf ircd.conf
+
+ keepdir var/{lib,log}/${PN}
+
+ # Ensure that if `make install' created /var/run/${PN}, we still
+ # force the initscript to create that directory.
+ rm -rf "${D}"/var/run || die
+
+ # charybdis ircd needs writing to its state (bandb) and log directories
+ fowners :charybdis /var/{lib,log}/${PN}
+ fperms 770 /var/{lib,log}/${PN}
+
+ # ensure that charybdis can access but not modify its configuration
+ # while protecting it from others
+ fowners :charybdis /etc/${PN}{,/ircd.conf}
+ fperms 750 /etc/${PN}
+ fperms 640 /etc/${PN}/ircd.conf
+}
+
+pkg_postinst() {
+ elog "All of the charybdis binaries in PATH have been prefixed with"
+ elog "'charybdis-' to prevent file collisions."
+}
diff --git a/net-irc/charybdis/files/charybdis-3.4.0-testline-crash-fix.patch b/net-irc/charybdis/files/charybdis-3.4.0-testline-crash-fix.patch
new file mode 100644
index 000000000000..0e72f7d21393
--- /dev/null
+++ b/net-irc/charybdis/files/charybdis-3.4.0-testline-crash-fix.patch
@@ -0,0 +1,20 @@
+commit 047a9b1ab072b8103ec954adc2f75baf2e9be553
+Author: Jilles Tjoelker <jilles@stack.nl>
+Date: Thu Oct 18 15:54:24 2012 +0200
+
+ Fix a crash with testline, introduced with the "underlying ipv4" feature.
+ (cherry picked from commit 6387b5ad4472d1a8f8fbd0b7f3f32dd9d8542072)
+
+diff --git a/src/hostmask.c b/src/hostmask.c
+index 99899af..fb28bbb 100644
+--- a/src/hostmask.c
++++ b/src/hostmask.c
+@@ -422,7 +422,7 @@ find_address_conf(const char *host, const char *sockhost, const char *user,
+ }
+
+ #ifdef RB_IPV6
+- if(ip->sa_family == AF_INET6 &&
++ if(ip != NULL && ip->sa_family == AF_INET6 &&
+ ipv4_from_ipv6((const struct sockaddr_in6 *)(const void *)ip, &ip4))
+ {
+ kconf = find_conf_by_address(NULL, NULL, NULL, (struct sockaddr *)&ip4, CONF_KILL, AF_INET, vuser, NULL);