summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-04-26 11:05:18 +0000
committerMarkus Meier <maekke@gentoo.org>2008-04-26 11:05:18 +0000
commitea3d2c04cad4517ff6aae3e532749f764749aa12 (patch)
treea4079351a74984f4f48b3007af5e84be9941338f /net-irc/inspircd/inspircd-1.1.19.ebuild
parentNew version (diff)
downloadgentoo-2-ea3d2c04cad4517ff6aae3e532749f764749aa12.tar.gz
gentoo-2-ea3d2c04cad4517ff6aae3e532749f764749aa12.tar.bz2
gentoo-2-ea3d2c04cad4517ff6aae3e532749f764749aa12.zip
fix cp for openssl in src_unpack, fix ipv6 detection, x86 stable (security bug #215704)
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-irc/inspircd/inspircd-1.1.19.ebuild')
-rw-r--r--net-irc/inspircd/inspircd-1.1.19.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-irc/inspircd/inspircd-1.1.19.ebuild b/net-irc/inspircd/inspircd-1.1.19.ebuild
index 58a764f457ce..181d080fe55a 100644
--- a/net-irc/inspircd/inspircd-1.1.19.ebuild
+++ b/net-irc/inspircd/inspircd-1.1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.19.ebuild,v 1.1 2008/04/23 19:04:01 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.19.ebuild,v 1.2 2008/04/26 11:05:18 maekke Exp $
inherit eutils toolchain-funcs multilib # subversion
@@ -11,7 +11,7 @@ mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="openssl gnutls ipv6 kernel_linux mysql postgres sqlite zlib ldap"
RDEPEND="
@@ -38,7 +38,7 @@ src_unpack() {
fi
if use openssl || use gnutls ; then
cp extra/m_sslinfo.cpp .
- cp extra/m_ssl_oper_cert.cpp
+ cp extra/m_ssl_oper_cert.cpp .
fi
if use ldap ; then
@@ -68,7 +68,7 @@ src_compile() {
# so should be used only --enable-like.
local myconf=""
use gnutls && myconf="--enable-gnutls"
- use myconf && myconf="${myconf} --enable-ipv6 --enable-remote-ipv6"
+ use ipv6 && myconf="${myconf} --enable-ipv6 --enable-remote-ipv6"
use openssl && myconf="${myconf} --enable-openssl"
./configure ${myconf} \