summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-11 12:39:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-11 12:39:53 +0000
commit2bc7a5a42e5d59a94406f99b92c581579e1750a7 (patch)
tree613f33e741bed55913ec395345240c8bfb08fa7b /net-irc/inspircd
parentAdding graphicsmagick dependency (Bug #314407) (diff)
downloadgentoo-2-2bc7a5a42e5d59a94406f99b92c581579e1750a7.tar.gz
gentoo-2-2bc7a5a42e5d59a94406f99b92c581579e1750a7.tar.bz2
gentoo-2-2bc7a5a42e5d59a94406f99b92c581579e1750a7.zip
drop 2 oldest, fails to build with gcc-4.4 and openssl-1
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/files/inspircd-1.1.19-build.patch14
-rw-r--r--net-irc/inspircd/inspircd-1.1.19.ebuild124
-rw-r--r--net-irc/inspircd/inspircd-1.1.23.ebuild124
3 files changed, 0 insertions, 262 deletions
diff --git a/net-irc/inspircd/files/inspircd-1.1.19-build.patch b/net-irc/inspircd/files/inspircd-1.1.19-build.patch
deleted file mode 100644
index 1b45d357778c..000000000000
--- a/net-irc/inspircd/files/inspircd-1.1.19-build.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-fix building with newer glibc
-
-http://bugs.gentoo.org/251446
-
---- src/configreader.cpp
-+++ src/configreader.cpp
-@@ -13,6 +13,7 @@
-
- #include "inspircd.h"
- #include "configreader.h"
-+#include <limits.h>
- #include <sstream>
- #include <fstream>
- #include "xline.h"
diff --git a/net-irc/inspircd/inspircd-1.1.19.ebuild b/net-irc/inspircd/inspircd-1.1.19.ebuild
deleted file mode 100644
index 571398456efb..000000000000
--- a/net-irc/inspircd/inspircd-1.1.19.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.19.ebuild,v 1.8 2011/04/26 14:41:35 xarthisius Exp $
-
-inherit eutils toolchain-funcs multilib # subversion
-
-DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
-HOMEPAGE="http://www.inspircd.org/"
-SRC_URI="http://www.inspircd.org/downloads/InspIRCd-${PV}.tar.bz2
- mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="openssl gnutls ipv6 kernel_linux mysql postgres sqlite zlib ldap"
-
-RDEPEND="dev-lang/perl
- openssl? ( dev-libs/openssl )
- gnutls? ( net-libs/gnutls )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-server )
- sqlite? ( >=dev-db/sqlite-3.0 )
- ldap? ( net-nds/openldap )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-build.patch #251446
-
- local SQL=0
- cd src/modules
-
- if use zlib ; then
- cp extra/m_ziplink.cpp .
- fi
- if use openssl || use gnutls ; then
- cp extra/m_sslinfo.cpp .
- cp extra/m_ssl_oper_cert.cpp .
- fi
-
- if use ldap ; then
- cp extra/m_ldapauth.cpp .
- fi
-
- if use mysql ; then
- SQL=1
- cp extra/m_mysql.cpp .
- fi
- if use postgres ; then
- SQL=1
- cp extra/m_pgsql.cpp .
- fi
- if use sqlite ; then
- SQL=1
- cp extra/m_sqlite3.cpp .
- fi
- if [ ${SQL} -eq 1 ] ; then
- cp extra/m_sql{auth.cpp,log.cpp,oper.cpp,utils.cpp,utils.h,v2.h} .
- fi
-}
-
-src_compile() {
- # ./configure doesn't know --disable-gnutls, -ipv6 and -openssl options,
- # so should be used only --enable-like.
- local myconf=""
- use gnutls && myconf="--enable-gnutls"
- use ipv6 && myconf="${myconf} --enable-ipv6 --enable-remote-ipv6"
- use openssl && myconf="${myconf} --enable-openssl"
-
- ./configure ${myconf} \
- --enable-epoll \
- --prefix="/usr/$(get_libdir)/inspircd" \
- --config-dir="/etc/inspircd" \
- --binary-dir="/usr/bin" \
- --library-dir="/usr/$(get_libdir)/inspircd" \
- --module-dir="/usr/$(get_libdir)/inspircd/modules" \
- || die "configure failed"
- ./configure -modupdate || die "modupdate failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # the inspircd buildsystem does not create these, its configure script
- # does. so, we have to make sure they are there.
- dodir /usr/$(get_libdir)/inspircd
- dodir /usr/$(get_libdir)/inspircd/modules
- dodir /etc/inspircd
- dodir /var/log/inspircd
- dodir /usr/include/inspircd
-
- emake install \
- LIBPATH="${D}/usr/$(get_libdir)/inspircd/" \
- MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
- CONPATH="${D}/etc/inspircd" \
- BINPATH="${D}/usr/bin" \
- BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher" \
- || die
-
- insinto /usr/include/inspircd/
- doins "${S}"/include/*
-
- newinitd "${FILESDIR}"/init.d_inspircd inspircd
-
- keepdir "/var/log/inspircd/"
-}
-
-pkg_postinst() {
- enewgroup inspircd
- enewuser inspircd -1 -1 -1 inspircd
- chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
- chmod 700 "${ROOT}"/etc/inspircd
-
- chmod 750 "${ROOT}"/var/log/inspircd
- chown -R inspircd:inspircd "${ROOT}"/var/log/inspircd
-
- chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
- chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
-
- chmod -R 755 "${ROOT}"/usr/bin/inspircd
-}
diff --git a/net-irc/inspircd/inspircd-1.1.23.ebuild b/net-irc/inspircd/inspircd-1.1.23.ebuild
deleted file mode 100644
index 3856b8cacba8..000000000000
--- a/net-irc/inspircd/inspircd-1.1.23.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.23.ebuild,v 1.3 2011/04/26 14:41:35 xarthisius Exp $
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
-HOMEPAGE="http://www.inspircd.org/"
-SRC_URI="http://www.inspircd.org/downloads/InspIRCd-${PV}.tar.bz2
-mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="openssl gnutls ipv6 kernel_linux mysql postgres sqlite zlib ldap"
-
-RDEPEND="
- dev-lang/perl
- openssl? ( dev-libs/openssl )
- gnutls? ( net-libs/gnutls )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-server )
- sqlite? ( >=dev-db/sqlite-3.0 )
- ldap? ( net-nds/openldap )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/inspircd"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- local SQL=0
- cd src/modules
-
- if use zlib ; then
- cp extra/m_ziplink.cpp .
- fi
- if use openssl || use gnutls ; then
- cp extra/m_sslinfo.cpp .
- cp extra/m_ssl_oper_cert.cpp .
- fi
-
- if use ldap ; then
- cp extra/m_ldapauth.cpp .
- fi
-
- if use mysql ; then
- SQL=1
- cp extra/m_mysql.cpp .
- fi
- if use postgres ; then
- SQL=1
- cp extra/m_pgsql.cpp .
- fi
- if use sqlite ; then
- SQL=1
- cp extra/m_sqlite3.cpp .
- fi
- if [ ${SQL} -eq 1 ] ; then
- cp extra/m_sql{auth.cpp,log.cpp,oper.cpp,utils.cpp,utils.h,v2.h} .
- fi
-}
-
-src_compile() {
-
- # ./configure doesn't know --disable-gnutls, -ipv6 and -openssl options,
- # so should be used only --enable-like.
- local myconf=""
- use gnutls && myconf="--enable-gnutls"
- use ipv6 && myconf="${myconf} --enable-ipv6 --enable-remote-ipv6"
- use openssl && myconf="${myconf} --enable-openssl"
-
- ./configure ${myconf} \
- --enable-epoll \
- --prefix="/usr/$(get_libdir)/inspircd" \
- --config-dir="/etc/inspircd" \
- --binary-dir="/usr/bin" \
- --library-dir="/usr/$(get_libdir)/inspircd" \
- --module-dir="/usr/$(get_libdir)/inspircd/modules" \
- || die "configure failed"
- ./configure -modupdate || die "modupdate failed"
-
- emake CC="$(tc-getCXX)" || die "emake failed"
-}
-
-src_install() {
- # the inspircd buildsystem does not create these, its configure script
- # does. so, we have to make sure they are there.
- dodir /usr/$(get_libdir)/inspircd
- dodir /usr/$(get_libdir)/inspircd/modules
- dodir /etc/inspircd
- dodir /var/log/inspircd
- dodir /usr/include/inspircd
-
- emake install \
- LIBPATH="${D}/usr/$(get_libdir)/inspircd/" \
- MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
- CONPATH="${D}/etc/inspircd" \
- BINPATH="${D}/usr/bin" \
- BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher"
-
- insinto /usr/include/inspircd/
- doins "${S}"/include/*
-
- newinitd "${FILESDIR}"/init.d_inspircd inspircd
-
- keepdir "/var/log/inspircd/"
-}
-
-pkg_postinst() {
- enewgroup inspircd
- enewuser inspircd -1 -1 -1 inspircd
- chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
- chmod 700 "${ROOT}"/etc/inspircd
-
- chmod 750 "${ROOT}"/var/log/inspircd
- chown -R inspircd:inspircd "${ROOT}"/var/log/inspircd
-
- chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
- chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
-
- chmod -R 755 "${ROOT}"/usr/bin/inspircd
-}