summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-06-28 13:11:30 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-06-28 13:11:30 +0000
commit4ba7388aeef19a134072d3cb4dd63193ba58f03b (patch)
tree986af96f1423c85b9327a12ad750ffb12fb66249 /net-irc/kvirc
parentia64 stable wrt #178750 (diff)
downloadgentoo-2-4ba7388aeef19a134072d3cb4dd63193ba58f03b.tar.gz
gentoo-2-4ba7388aeef19a134072d3cb4dd63193ba58f03b.tar.bz2
gentoo-2-4ba7388aeef19a134072d3cb4dd63193ba58f03b.zip
Add svn snapshot with fixed security bug #183174 and fixed crash-on-initial-setup bugs
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'net-irc/kvirc')
-rw-r--r--net-irc/kvirc/ChangeLog9
-rw-r--r--net-irc/kvirc/files/digest-kvirc-3.2.6_pre200706283
-rw-r--r--net-irc/kvirc/kvirc-3.2.6_pre20070628.ebuild61
3 files changed, 72 insertions, 1 deletions
diff --git a/net-irc/kvirc/ChangeLog b/net-irc/kvirc/ChangeLog
index 69800bc71821..5ec133abbbb7 100644
--- a/net-irc/kvirc/ChangeLog
+++ b/net-irc/kvirc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/kvirc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.46 2007/05/01 11:17:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.47 2007/06/28 13:11:30 jokey Exp $
+
+*kvirc-3.2.6_pre20070628 (28 Jun 2007)
+
+ 28 Jun 2007; Markus Ullmann <jokey@gentoo.org>
+ +kvirc-3.2.6_pre20070628.ebuild:
+ Add svn snapshot with fixed security bug #183174 and fixed
+ crash-on-initial-setup bugs
01 May 2007; Raúl Porcel <armin76@gentoo.org>
files/kvirc-svn-kdedir-fix.patch:
diff --git a/net-irc/kvirc/files/digest-kvirc-3.2.6_pre20070628 b/net-irc/kvirc/files/digest-kvirc-3.2.6_pre20070628
new file mode 100644
index 000000000000..5d29674d1473
--- /dev/null
+++ b/net-irc/kvirc/files/digest-kvirc-3.2.6_pre20070628
@@ -0,0 +1,3 @@
+MD5 52d0ee34622257118e94537ee9d3f340 kvirc-3.2.6_pre20070628.tar.bz2 5344435
+RMD160 7e9f9f04970610c76b4bbfee1fde61e66bc5640d kvirc-3.2.6_pre20070628.tar.bz2 5344435
+SHA256 f829c5f5c6eddd63ce8ce84e429e62ab0371c734facd691a59fdcb9ccc3e9483 kvirc-3.2.6_pre20070628.tar.bz2 5344435
diff --git a/net-irc/kvirc/kvirc-3.2.6_pre20070628.ebuild b/net-irc/kvirc/kvirc-3.2.6_pre20070628.ebuild
new file mode 100644
index 000000000000..09e8e2f99d10
--- /dev/null
+++ b/net-irc/kvirc/kvirc-3.2.6_pre20070628.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.2.6_pre20070628.ebuild,v 1.1 2007/06/28 13:11:30 jokey Exp $
+
+inherit autotools eutils kde-functions
+
+DESCRIPTION="An advanced IRC Client"
+HOMEPAGE="http://www.kvirc.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="kvirc"
+SLOT="3"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="debug esd ipv6 kde oss ssl"
+
+RDEPEND="esd? ( media-sound/esound )
+ ssl? ( dev-libs/openssl )
+ oss? ( media-libs/audiofile )
+ kde? ( >=kde-base/kdelibs-3 )
+ =x11-libs/qt-3*"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ./autogen.sh
+ epatch "${FILESDIR}"/${PN}-svn-kdedir-fix.patch
+}
+
+src_compile() {
+ set-qtdir 3
+ set-kdedir 3
+
+ # use aa even when kde support is disabled; remove the splash screen
+ # to speed up the startup.
+ local myconf="--with-aa-fonts --without-splash-screen
+ --with-big-channels --with-pizza"
+
+ # For myconf, we can't do it the easy way (use_with) because the configure
+ # script will assume we're telling it not to include support.
+ myconf="${myconf} `use_with debug debug-symbols`"
+ use kde || myconf="${myconf} --without-kde-support --without-arts-support"
+ use ipv6 || myconf="${myconf} --without-ipv6-support"
+ use esd || myconf="${myconf} --without-esd-support"
+ use ssl || myconf="${myconf} --without-ssl-support"
+
+ [ "${ARCH}" == "x86" ] && myconf="${myconf} --with-ix86-asm"
+
+ econf ${myconf} || die "econf failed"
+ emake -j1 || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" docs || die "emake docs failed"
+ dodoc ChangeLog INSTALL README TODO
+}