summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-15 23:30:53 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-15 23:30:53 +0000
commit4578aad07fc2e0f49860ca465e90cde4addd8efb (patch)
tree1d1e5cebb050acdcc28bf53b07b9b898b4572889 /net-irc/rbot
parentversion bump (diff)
downloadgentoo-2-4578aad07fc2e0f49860ca465e90cde4addd8efb.tar.gz
gentoo-2-4578aad07fc2e0f49860ca465e90cde4addd8efb.tar.bz2
gentoo-2-4578aad07fc2e0f49860ca465e90cde4addd8efb.zip
Remove masked rbot version (ruby18-only).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-irc/rbot')
-rw-r--r--net-irc/rbot/ChangeLog5
-rw-r--r--net-irc/rbot/rbot-0.9.15.ebuild172
2 files changed, 4 insertions, 173 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index 491c910e121a..3396be3ea2ee 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/rbot
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.56 2014/01/18 14:47:53 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.57 2014/03/15 23:30:53 mrueg Exp $
+
+ 15 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -rbot-0.9.15.ebuild:
+ Remove masked rbot version (ruby18-only).
18 Jan 2014; Anthony G. Basile <blueness@gentoo.org>
rbot-0.9.15_p20131020.ebuild:
diff --git a/net-irc/rbot/rbot-0.9.15.ebuild b/net-irc/rbot/rbot-0.9.15.ebuild
deleted file mode 100644
index 8e5131798998..000000000000
--- a/net-irc/rbot/rbot-0.9.15.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.15.ebuild,v 1.8 2013/01/12 08:24:44 ulm Exp $
-
-EAPI="2"
-# ruby19 needs ruby-gettext on 19 first
-USE_RUBY="ruby18"
-
-inherit ruby-ng eutils user
-
-DESCRIPTION="rbot is a ruby IRC bot"
-HOMEPAGE="http://ruby-rbot.org/"
-SRC_URI="http://ruby-rbot.org/download/${P}.tgz"
-
-LICENSE="|| ( feh GPL-2 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86 ~x86-fbsd"
-IUSE="spell aspell timezone translator shorturl nls dict figlet
- fortune cal host toilet"
-ILINGUAS="zh_CN zh_TW ru nl de fi fr it ja"
-
-for lang in $ILINGUAS; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
-RDEPEND="
- spell? (
- aspell? ( app-text/aspell )
- !aspell? ( app-text/hunspell )
- )
- figlet? ( app-misc/figlet )
- toilet? ( app-misc/toilet )
- fortune? ( games-misc/fortune-mod )
- cal? ( || ( sys-apps/util-linux sys-freebsd/freebsd-ubin ) )
- host? ( net-dns/bind-tools )"
-
-ruby_add_rdepend "
- dev-ruby/ruby-bdb
- timezone? ( dev-ruby/tzinfo )
- translator? ( dev-ruby/mechanize )
- shorturl? ( dev-ruby/shorturl )
- nls? ( dev-ruby/ruby-gettext >=dev-ruby/locale-2.0.5-r2 )
- dict? ( dev-ruby/ruby-dict )"
-
-# gettext does not yet work on 1.9, so generate locales on 1.8
-DEPEND="
- nls? (
- >=dev-ruby/ruby-gettext-2[ruby_targets_ruby18]
- dev-ruby/rake[ruby_targets_ruby18]
- )"
-
-pkg_setup() {
- enewuser rbot -1 -1 /var/lib/rbot nobody
-}
-
-all_ruby_compile() {
- disable_rbot_plugin() {
- mv "${S}"/data/rbot/plugins/$1.rb{,.disabled}
- }
- use_rbot_plugin() {
- use $1 && return
- disable_rbot_plugin "$2"
- }
- rbot_conf() {
- echo "$1: $2" >> "${T}"/rbot.conf
- }
- use_rbot_conf_path() {
- use "$1" \
- && rbot_conf "$2" "$3" \
- || rbot_conf "$2" /bin/false
- }
-
- local spell_program="/usr/bin/hunspell -i"
- if use !spell; then
- disable_rbot_plugin spell
- spell_program="/bin/false"
- elif use aspell; then
- spell_program="/usr/bin/ispell-aspell"
- fi
-
- rbot_conf spell.program "${spell_program}"
-
- if use !figlet && use !toilet; then
- disable_rbot_plugin figlet
- fi
-
- use_rbot_conf_path figlet figlet.path /usr/bin/figlet
- use_rbot_conf_path toilet toilet.path /usr/bin/toilet
-
- use_rbot_plugin timezone time
- use_rbot_plugin translator translator
- use_rbot_plugin shorturl shortenurls
- use_rbot_plugin dict dictclient
-
- use_rbot_plugin fortune fortune
- use_rbot_conf_path fortune fortune.path /usr/bin/fortune
-
- use_rbot_plugin cal cal
- use_rbot_conf_path cal cal.path /usr/bin/cal
-
- use_rbot_plugin host host
- use_rbot_conf_path host host.path /usr/bin/host
-
- local rbot_datadir="${D}"/usr/share/rbot
-
- # This is unfortunately pretty manual at the moment, but it's just
- # to avoid having to run special scripts to package new versions
- # of rbot. The default if new languages are added that are not
- # considered for an opt-out here is to install them, so you just
- # need to add them later.
- if use nls; then
- strip-linguas ${ILINGUAS}
- if [[ -n ${LINGUAS} ]]; then
- # As the the language name used by the rbot data files does
- # not correspond to the ISO codes we usually use for LINGUAS,
- # the following list of local varables will work as a
- # dictionary to get the name used by rbot from the ISO code.
- local lang_rbot_zh_CN="traditional_chinese"
- local lang_rbot_ru="russian"
- local lang_rbot_nl="dutch"
- local lang_rbot_de="german"
- local lang_rbot_fi="finnish"
- local lang_rbot_fr="french"
- local lang_rbot_it="italian"
- local lang_rbot_ja="japanese"
-
- for lang in ${ILINGUAS}; do
- use linguas_${lang} && continue
-
- lang_varname="lang_rbot_${lang}"
- lang_rbot=${!lang_varname}
-
- rm -r \
- "${S}"/data/rbot/languages/${lang_rbot}.lang \
- "${S}"/data/rbot/templates/lart/larts-${lang_rbot} \
- "${S}"/data/rbot/templates/lart/praises-${lang_rbot} \
- "${S}"/data/rbot/templates/salut/salut-${lang_rbot} \
- "${S}"/po/${lang} &>/dev/null
- done
- fi
-
- ruby18 /usr/bin/rake makemo || die "locale generation failed"
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} setup.rb config --prefix="/usr" \
- || die "setup.rb install failed"
-}
-
-each_ruby_install() {
- ${RUBY} setup.rb install --prefix="${D}" \
- || die "setup.rb install failed"
-}
-
-all_ruby_install() {
- diropts -o rbot -g nobody -m 0700
- keepdir /var/lib/rbot
-
- insinto /etc
- doins "${T}"/rbot.conf
-
- newinitd "${FILESDIR}/rbot.init2" rbot
- newconfd "${FILESDIR}/rbot.conf2" rbot
-}
-
-pkg_postinst() {
- einfo
- elog "rbot can be started as a normal service."
- elog "Check /etc/conf.d/rbot file for more information about this feature."
- einfo
-}