summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-08-24 22:43:23 +0000
committerSven Wegener <swegener@gentoo.org>2004-08-24 22:43:23 +0000
commit7a000a8a38953eeee0d876c8e053d5208190b147 (patch)
treea3111f6aa231f1a80502e42d0c61453ea2d4f49e /net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild
parentw00t, 142 bytes reduction with: optipng -zc9 -zm5 -zs0 -f0 screenshot.png ;) ... (diff)
downloadgentoo-2-7a000a8a38953eeee0d876c8e053d5208190b147.tar.gz
gentoo-2-7a000a8a38953eeee0d876c8e053d5208190b147.tar.bz2
gentoo-2-7a000a8a38953eeee0d876c8e053d5208190b147.zip
Revision bump for a patch that fixes segfaults on executing browser, mail client and multimedia player. Closes bug #61521.
Diffstat (limited to 'net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild')
-rw-r--r--net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild b/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild
new file mode 100644
index 000000000000..89db64a3f929
--- /dev/null
+++ b/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.4.5-r1.ebuild,v 1.1 2004/08/24 22:43:23 swegener Exp $
+
+inherit flag-o-matic eutils
+
+MY_P=${PN}-integration-${PV}
+
+DESCRIPTION="System tray plugin for X-Chat."
+SRC_URI="mirror://sourceforge/xchat2-plugins/${MY_P}-src.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://blight.altervista.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~ppc ~sparc ~alpha ~hppa"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ >=net-irc/xchat-2.0.3"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.7"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PV}-segfault-fix.patch
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake -j1 CFLAGS="${CFLAGS}" || die "Compile failed"
+}
+
+src_install() {
+ exeinto /usr/lib/xchat/plugins
+ doexe systray.so
+
+ insinto /usr/share/xchat-systray/GTKTray
+ doins src/images/GTKTray/*
+
+ insinto /usr/share/xchat-systray/Menu
+ doins src/images/Menu/*
+
+ dodoc Docs/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "As of 2.4.5 the images will be installed seperately and will not be included"
+ einfo "in the binary. The images have been installed in /usr/share/xchat-systray"
+ einfo
+ einfo "Please update your settings accordingly!"
+ einfo
+}