summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-09-05 11:45:25 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-09-05 11:45:25 +0000
commitafabf9b684b7cf284502d1d268e7c2d1c50ab86d (patch)
tree6b7e86392c9401cf75ac9b56aff51c6664dd476f /net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-afabf9b684b7cf284502d1d268e7c2d1c50ab86d.tar.gz
gentoo-2-afabf9b684b7cf284502d1d268e7c2d1c50ab86d.tar.bz2
gentoo-2-afabf9b684b7cf284502d1d268e7c2d1c50ab86d.zip
2.6 kernels report L2 cache information for Alphas, actually use it as suggested by Thomas Cort <tcort@gentoo.org> in bug #137217.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild')
-rw-r--r--net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild b/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..4a4844e5e0db
--- /dev/null
+++ b/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.1.0-r1.ebuild,v 1.1 2006/09/05 11:45:25 chainsaw Exp $
+
+inherit toolchain-funcs eutils
+
+MY_P="${P/xchat-/}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Sysinfo plugin for X-Chat."
+SRC_URI="http://dev.gentoo.org/~chainsaw/xsys/download/${MY_P}.tar.bz2 mirror://gentoo/${MY_P}.tar.bz2"
+HOMEPAGE="http://dev.gentoo.org/~chainsaw/xsys/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="audacious buttons xmms"
+
+DEPEND="|| (
+ >=net-irc/xchat-2.4.0
+ >=net-irc/xchat-gnome-0.4
+ )
+ sys-apps/pciutils
+ audacious? ( media-sound/audacious )
+ xmms? ( media-sound/xmms )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2 -Wall:${CFLAGS} -Wall:" Makefile
+ if use buttons; then
+ sed -i -e "s:#BUTTON:BUTTON:" Makefile
+ fi
+ if use audacious; then
+ sed -i -e "s:# FOR AUDACIOUS # ::g" Makefile
+ elif use xmms; then
+ sed -i -e "s:# FOR XMMS # ::g" Makefile
+ fi
+ epatch ${FILESDIR}/${PV}-alpha-L2-cache.patch
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" || die "Compile failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/xchat/plugins
+ doexe xsys-${PV}.so || die "doexe failed"
+
+ exeinto /usr/$(get_libdir)/xchat-gnome/plugins
+ doexe xsys-${PV}.so || die "doexe failed"
+
+ dodoc ChangeLog README || die "dodoc failed"
+}