summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-07-08 16:37:52 +0000
committerMarinus Schraal <foser@gentoo.org>2003-07-08 16:37:52 +0000
commit67c2456b63439b2296d7fe9f8ea310844d7a2720 (patch)
tree346e3c9a41ea5c1e52e0b244e809759972fc4abb /net-irc/xchat/xchat-2.0.3-r1.ebuild
parentadded dcc patch (diff)
downloadgentoo-2-67c2456b63439b2296d7fe9f8ea310844d7a2720.tar.gz
gentoo-2-67c2456b63439b2296d7fe9f8ea310844d7a2720.tar.bz2
gentoo-2-67c2456b63439b2296d7fe9f8ea310844d7a2720.zip
added dcc patch
Diffstat (limited to 'net-irc/xchat/xchat-2.0.3-r1.ebuild')
-rw-r--r--net-irc/xchat/xchat-2.0.3-r1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-irc/xchat/xchat-2.0.3-r1.ebuild b/net-irc/xchat/xchat-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..1ece09d2fd93
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.3-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.3-r1.ebuild,v 1.1 2003/07/08 16:37:41 foser Exp $
+
+inherit eutils
+
+IUSE="perl tcltk python ssl gtk mmx ipv6"
+
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ gtk? ( >=x11-libs/gtk+-2.0.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # fixes mmx problem
+ epatch ${FILESDIR}/${P}-fix_tint.patch
+ # fix dcc cps calculation
+ epatch ${FILESDIR}/${P}-fix_cps.patch
+
+}
+
+src_compile() {
+ local myopts
+
+ use gtk \
+ && myopts="${myopts} --enable-gtkfe" \
+ || myopts="${myopts} --disable-gtkfe"
+ use ssl \
+ && myopts="${myopts} --enable-openssl" \
+ || myopts="${myopts} --disable-openssl"
+ use perl \
+ && myopts="${myopts} --enable-perl" \
+ || myopts="${myopts} --disable-perl"
+ use python \
+ && myopts="${myopts} --enable-python" \
+ || myopts="${myopts} --disable-python"
+ use tcltk \
+ && myopts="${myopts} --enable-tcl" \
+ || myopts="${myopts} --disable-tcl"
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6" \
+ || myopts="${myopts} --disable-ipv6"
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h
+
+ dodoc AUTHORS COPYING ChangeLog README*
+}