summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-23 14:45:00 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-23 14:45:00 +0000
commitfd8dcec6788e284ef8f984f9c53e4bb31933b57d (patch)
tree2a938f977d8c4adb09c7f20f480c977b4219f00f /net-irc/xchat
parentcommited twisted 1.0.2alpha4 (diff)
downloadgentoo-2-fd8dcec6788e284ef8f984f9c53e4bb31933b57d.tar.gz
gentoo-2-fd8dcec6788e284ef8f984f9c53e4bb31933b57d.tar.bz2
gentoo-2-fd8dcec6788e284ef8f984f9c53e4bb31933b57d.zip
New version
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.111
-rw-r--r--net-irc/xchat/files/xc1811fixststint.diff14
-rw-r--r--net-irc/xchat/xchat-1.8.11.ebuild100
4 files changed, 121 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 9ae0203b8e78..0e5fda6db8a5 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.37 2003/01/04 00:22:27 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.38 2003/01/23 14:45:00 foser Exp $
+
+*xchat-1.8.11 (23 Jan 2003)
+
+ 23 Jan 2003; foser <foser@gentoo.org> xchat-1.8.11.ebuild :
+ New version, with patch, now slotted (#13607)
*xchat-1.9.8 (03 Jan 2003)
diff --git a/net-irc/xchat/files/digest-xchat-1.8.11 b/net-irc/xchat/files/digest-xchat-1.8.11
new file mode 100644
index 000000000000..feaf933fc312
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.11
@@ -0,0 +1 @@
+MD5 951f5b2fe2d5deef08f7f519414072a1 xchat-1.8.11.tar.bz2 850453
diff --git a/net-irc/xchat/files/xc1811fixststint.diff b/net-irc/xchat/files/xc1811fixststint.diff
new file mode 100644
index 000000000000..7ce4a99e4f33
--- /dev/null
+++ b/net-irc/xchat/files/xc1811fixststint.diff
@@ -0,0 +1,14 @@
+--- xchat-1.8.11/src/fe-gtk/xtext.c 2002-12-03 18:08:45.000000000 +1100
++++ xchat-1.8.11p1/src/fe-gtk/xtext.c 2003-01-05 20:56:01.000000000 +1100
+@@ -505,7 +505,11 @@
+ int height_only = FALSE;
+
+ if (allocation->width == widget->allocation.width)
++ {
++ if (allocation->height == widget->allocation.height)
++ return;
+ height_only = TRUE;
++ }
+
+ widget->allocation = *allocation;
+ if (GTK_WIDGET_REALIZED (widget))
diff --git a/net-irc/xchat/xchat-1.8.11.ebuild b/net-irc/xchat/xchat-1.8.11.ebuild
new file mode 100644
index 000000000000..5be29f4ebdcd
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.11.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.11.ebuild,v 1.1 2003/01/23 14:45:00 foser Exp $
+
+inherit eutils
+
+IUSE="ssl nls mmx gnome ipv6 python kde gtk perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ python? ( >=dev-lang/python-2.2-r7 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( <gnome-base/gnome-panel-1.5.0
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/xc1811fixststint.diff
+
+ use python && ( \
+ cp configure configure.orig
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' \
+ configure.orig > configure
+ )
+}
+
+src_compile() {
+
+ local myopts myflags
+
+ if [ ! `use perl` ]; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ CFLAGS="${CFLAGS} -I/usr/include/orbit-1.0" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
+ else
+ myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use nls \
+ && myopts="${myopts} --enable-nls --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls --disable-hebrew --disable-japanese-conv"
+
+ if use x86
+ then
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ fi
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+ use python \
+ && myflags="`python-config`" \
+ && myopts="${myopts} --enable-python"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ install || die
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop
+ )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}