summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-04-07 20:32:25 +0000
committerSven Wegener <swegener@gentoo.org>2005-04-07 20:32:25 +0000
commit4d6c5899db934fc0a4e9009e500ccee32fc88500 (patch)
tree748102479f7b2675a02a3fe6413a7a8f2a3993e9 /net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild
parentRemoving older versions and marking 230 stable. (diff)
downloadgentoo-2-4d6c5899db934fc0a4e9009e500ccee32fc88500.tar.gz
gentoo-2-4d6c5899db934fc0a4e9009e500ccee32fc88500.tar.bz2
gentoo-2-4d6c5899db934fc0a4e9009e500ccee32fc88500.zip
Initial commit, thanks to Jeff Davidson in bug #78338.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild')
-rw-r--r--net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild b/net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild
new file mode 100644
index 000000000000..0465be996caf
--- /dev/null
+++ b/net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xdcc-fetch/xdcc-fetch-1.409.ebuild,v 1.1 2005/04/07 20:32:25 swegener Exp $
+
+inherit eutils
+
+MY_PN="XDCC-Fetch"
+
+DESCRIPTION="A tool for search, collecting, and downloading XDCC announcements within IRC channels, written in Ruby."
+HOMEPAGE="http://xdccfetch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xdccfetch/${MY_PN}-${PV}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8
+ >=dev-ruby/fxruby-1.2"
+
+S=${WORKDIR}/${MY_PN}
+
+src_install() {
+ exeinto /usr/share/${PN}
+ doexe ${MY_PN}.rbw || die "doexe failed"
+
+ make_wrapper ${PN} /usr/share/${PN}/${MY_PN}.rbw .
+
+ insinto /usr/share/${PN}
+ doins -r icons src || die "doins failed"
+
+ dodoc COPYING || die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
+}