summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2009-11-16 23:36:03 +0000
committerDawid Węgliński <cla@gentoo.org>2009-11-16 23:36:03 +0000
commit6ace75aca21952dec31bd00eb4506b2b9d93c572 (patch)
tree9db5bda1d65c814263988a349e8f6e6f5fa2d6ef /net-irc/znc
parentInstall cups backend to correct directory, bug 293441. (diff)
downloadgentoo-2-6ace75aca21952dec31bd00eb4506b2b9d93c572.tar.gz
gentoo-2-6ace75aca21952dec31bd00eb4506b2b9d93c572.tar.bz2
gentoo-2-6ace75aca21952dec31bd00eb4506b2b9d93c572.zip
Version bump (bug #293134)
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.076.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 84c1976b6145..eb8c8270b582 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.25 2009/08/14 17:50:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.26 2009/11/16 23:36:03 cla Exp $
+
+*znc-0.076 (16 Nov 2009)
+
+ 16 Nov 2009; Dawid Węgliński <cla@gentoo.org> +znc-0.076.ebuild:
+ Version bump (bug #293134)
14 Aug 2009; Markus Meier <maekke@gentoo.org> znc-0.074.ebuild:
amd64 stable, bug #278684
diff --git a/net-irc/znc/znc-0.076.ebuild b/net-irc/znc/znc-0.076.ebuild
new file mode 100644
index 000000000000..ac4d4c854f6f
--- /dev/null
+++ b/net-irc/znc/znc-0.076.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.076.ebuild,v 1.1 2009/11/16 23:36:03 cla Exp $
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ares debug ipv6 nomodules perl ssl sasl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ares? ( net-dns/c-ares )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable !nomodules modules) \
+ $(use_enable perl) \
+ $(use_enable ssl openssl) \
+ $(use_enable sasl) \
+ $(use_enable ares c-ares) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS znc.conf || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}