summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-01-21 13:38:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-01-21 13:38:17 +0000
commit063948a7bb2170969913d1c0a5078070996fc3fe (patch)
treeebc2e76d27c1ede1a85d23785c7d8ce91cad87c2 /net-irc
parentStable for ppc64, wrt bug #452692 (diff)
downloadgentoo-2-063948a7bb2170969913d1c0a5078070996fc3fe.tar.gz
gentoo-2-063948a7bb2170969913d1c0a5078070996fc3fe.tar.bz2
gentoo-2-063948a7bb2170969913d1c0a5078070996fc3fe.zip
Update to eapi5 an python-single-r1.
(Portage version: 2.2.0_alpha157/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/ChangeLog6
-rw-r--r--net-irc/weechat/weechat-0.4.0.ebuild14
-rw-r--r--net-irc/weechat/weechat-9999.ebuild16
3 files changed, 18 insertions, 18 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index c1aff25416ee..5c08e96e12ab 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/weechat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.125 2013/01/21 12:53:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.126 2013/01/21 13:38:17 scarabeus Exp $
+
+ 21 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org> weechat-0.4.0.ebuild,
+ weechat-9999.ebuild:
+ Update to eapi5 an python-single-r1.
*weechat-0.4.0 (21 Jan 2013)
diff --git a/net-irc/weechat/weechat-0.4.0.ebuild b/net-irc/weechat/weechat-0.4.0.ebuild
index 75b0aaca4358..ce1395fe2910 100644
--- a/net-irc/weechat/weechat-0.4.0.ebuild
+++ b/net-irc/weechat/weechat-0.4.0.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.4.0.ebuild,v 1.1 2013/01/21 12:53:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.4.0.ebuild,v 1.2 2013/01/21 13:38:17 scarabeus Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="python? 2" # it can use only ONE python, so stick with two for now
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
-inherit python multilib cmake-utils ${GIT_ECLASS}
+inherit python-single-r1 multilib cmake-utils ${GIT_ECLASS}
DESCRIPTION="Portable and multi-interface IRC client."
HOMEPAGE="http://weechat.org/"
@@ -36,6 +36,7 @@ RDEPEND="
irc? ( dev-libs/libgcrypt )
lua? ( dev-lang/lua[deprecated] )
perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
ruby? ( >=dev-lang/ruby-1.9 )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
@@ -57,10 +58,7 @@ for X in "${LANGS[@]}" ; do
done
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 9eeb20d7429b..f82a550aa7b1 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.23 2012/11/19 17:37:10 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.24 2013/01/21 13:38:17 scarabeus Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="python? 2" # it can use only ONE python, so stick with two for now
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
-inherit python multilib cmake-utils ${GIT_ECLASS}
+inherit python-single-r1 multilib cmake-utils ${GIT_ECLASS}
DESCRIPTION="Portable and multi-interface IRC client."
HOMEPAGE="http://weechat.org/"
@@ -36,6 +36,7 @@ RDEPEND="
irc? ( dev-libs/libgcrypt )
lua? ( dev-lang/lua[deprecated] )
perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
ruby? ( >=dev-lang/ruby-1.9 )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
@@ -57,10 +58,7 @@ for X in "${LANGS[@]}" ; do
done
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
+ use python && python-single-r1_pkg_setup
}
src_prepare() {