summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-09-04 12:47:56 +0000
committerMike Gardiner <obz@gentoo.org>2003-09-04 12:47:56 +0000
commit4ae3c0b709cc00cafd5faf3e761e95362faa25b9 (patch)
tree9037ec19604944a0ed0f760eb299baeff75ace1e /net-irc
parentAdded local use flags xchattext and xchatnogtk (diff)
downloadgentoo-2-4ae3c0b709cc00cafd5faf3e761e95362faa25b9.tar.gz
gentoo-2-4ae3c0b709cc00cafd5faf3e761e95362faa25b9.tar.bz2
gentoo-2-4ae3c0b709cc00cafd5faf3e761e95362faa25b9.zip
erm, really added the use variables this time
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/Manifest2
-rw-r--r--net-irc/xchat/xchat-2.0.4.ebuild36
2 files changed, 17 insertions, 21 deletions
diff --git a/net-irc/xchat/Manifest b/net-irc/xchat/Manifest
index ae2d1222f798..555f54992793 100644
--- a/net-irc/xchat/Manifest
+++ b/net-irc/xchat/Manifest
@@ -3,7 +3,7 @@ MD5 849da81b46b8b7ea36a6454227a1f12d xchat-1.8.11.ebuild 2230
MD5 bc68023a361d1a90c51651cc396d6bc3 xchat-2.0.0.ebuild 1929
MD5 02f182c540386303cb887a0aacbdfd2c xchat-2.0.2-r2.ebuild 2152
MD5 d6896c2421454aab5a0cefef7bed9946 xchat-1.8.10-r1.ebuild 2307
-MD5 1d8f21e5f7841714abf1abe19ca2329b xchat-2.0.4.ebuild 2057
+MD5 e2674739008fb72a1bfed06d07d46694 xchat-2.0.4.ebuild 2034
MD5 f9c4e7ed38d056126a37bb1360cbbba0 ChangeLog 9800
MD5 fb5772136a872c08434566d4f0bcdc7f metadata.xml 179
MD5 abb6ce9b6db024b87209f10ee70f0889 xchat-2.0.3-r1.ebuild 1926
diff --git a/net-irc/xchat/xchat-2.0.4.ebuild b/net-irc/xchat/xchat-2.0.4.ebuild
index 14688928385a..7a4bf59b342d 100644
--- a/net-irc/xchat/xchat-2.0.4.ebuild
+++ b/net-irc/xchat/xchat-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.4.ebuild,v 1.7 2003/09/04 12:38:31 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.4.ebuild,v 1.8 2003/09/04 12:47:35 obz Exp $
inherit eutils
@@ -12,16 +12,18 @@ LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa"
IUSE="perl tcltk python ssl gtk mmx ipv6 nls"
+# Local use flag for the text frontend (bug #26427)
+IUSE="${IUSE} xchattext xchatnogtk"
# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
if [ ${ARCH} = "sparc" ]
then
- replace-flags "-O3" "-O2"
+ replace-flags "-O3" "-O2"
fi
RDEPEND=">=dev-libs/glib-2.0.3
- gtk? ( >=x11-libs/gtk+-2.0.3 )
+ !xchatnogtk ( >=x11-libs/gtk+-2.0.3 )
perl? ( >=dev-lang/perl-5.6.1 )
ssl? ( >=dev-libs/openssl-0.9.6d )
python? ( dev-lang/python )
@@ -35,9 +37,15 @@ src_compile() {
# xchat's configure script uses sys.path to find library path
# instead of python-config (#25943)
unset PYTHONPATH
-
+
+ # test for local usage of xchatnogtk
+ local gtkconf
+ use xchatnogtk \
+ && gtkconf="--disable-gtkfe" \
+ || gtkconf="--enable-gtkfe"
+
econf \
- `use_enable gtk gtkfe` \
+ ${gtkconf} \
`use_enable ssl openssl` \
`use_enable perl` \
`use_enable python` \
@@ -45,10 +53,10 @@ src_compile() {
`use_enable mmx` \
`use_enable ipv6` \
`use_enable nls` \
- --enable-textfe \
+ `use_enable xchattext textfe` \
--program-suffix=-2 \
|| die "Configure failed"
-
+
MAKEOPTS="-j1" emake || die "Compile failed"
}
@@ -60,21 +68,9 @@ src_install() {
einstall install || die "Install failed"
# install plugin development header
- insinto /usr/include/xchat
+ insinto /usr/include/xchat
doins src/common/xchat-plugin.h
dodoc AUTHORS COPYING ChangeLog README*
}
-pkg_postinst( ) {
-
- # warnings for people for who USE="gtk2 -gtk" doesnt behave as
- # they expect, see bug #26427
- if [ ! `use gtk` ]; then
- echo ""
- ewarn "If you wish to use the gtk2 frontend for xchat, please"
- ewarn "USE=\"gtk\" emerge xchat"
- echo ""
- fi
-
-}