summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-07-28 11:27:43 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-07-28 11:27:43 +0000
commit5d89cbe186695c76c8de6995feb685377e174919 (patch)
tree51e72f7ff7ad8c01187d7690beafe8e33600e1b5 /net-irc
parentAdd 0.50.2 (diff)
downloadgentoo-2-5d89cbe186695c76c8de6995feb685377e174919.tar.gz
gentoo-2-5d89cbe186695c76c8de6995feb685377e174919.tar.bz2
gentoo-2-5d89cbe186695c76c8de6995feb685377e174919.zip
Fixed bug #330007.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog9
-rw-r--r--net-irc/xchat/files/xchat-input-box4.patch (renamed from net-irc/xchat/files/xchat-input-box3.patch)11
-rw-r--r--net-irc/xchat/xchat-2.8.8.ebuild4
3 files changed, 12 insertions, 12 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index f0cf85222c4f..e842717096d5 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.282 2010/07/26 13:33:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.283 2010/07/28 11:27:43 polynomial-c Exp $
+
+ 28 Jul 2010; Lars Wendler <polynomial-c@gentoo.org>
+ -files/xchat-input-box3.patch, xchat-2.8.8.ebuild,
+ +files/xchat-input-box4.patch:
+ Fixed placement of channelstatus dot at the left side of the input box.
+ Thanks to Westly Ward for reporting this issue in bug #330007 and Rafał
+ Mużyło for providing a fixed patch.
26 Jul 2010; Christian Faulhammer <fauli@gentoo.org> xchat-2.8.8.ebuild:
stable x86, bug 329835
diff --git a/net-irc/xchat/files/xchat-input-box3.patch b/net-irc/xchat/files/xchat-input-box4.patch
index 7055c7be7b73..74ee77a8678e 100644
--- a/net-irc/xchat/files/xchat-input-box3.patch
+++ b/net-irc/xchat/files/xchat-input-box4.patch
@@ -1,6 +1,6 @@
--- src/fe-gtk/maingui.c.old 2010-05-16 05:15:55.000000000 +0200
-+++ src/fe-gtk/maingui.c 2010-07-20 23:49:11.000000000 +0200
-@@ -2828,13 +2828,13 @@
++++ src/fe-gtk/maingui.c 2010-07-27 05:10:22.000000000 +0200
+@@ -2828,7 +2828,7 @@
static void
mg_create_entry (session *sess, GtkWidget *box)
{
@@ -9,13 +9,6 @@
session_gui *gui = sess->gui;
hbox = gtk_hbox_new (FALSE, 0);
- gtk_box_pack_start (GTK_BOX (box), hbox, 0, 0, 0);
-
-- gui->nick_box = gtk_hbox_new (FALSE, 0);
-+ gui->nick_box = gtk_vbox_new (FALSE, 0);
- gtk_box_pack_start (GTK_BOX (hbox), gui->nick_box, 0, 0, 0);
-
- gui->nick_label = but = gtk_button_new_with_label (sess->server->nick);
@@ -2846,7 +2846,7 @@
#ifdef USE_GTKSPELL
diff --git a/net-irc/xchat/xchat-2.8.8.ebuild b/net-irc/xchat/xchat-2.8.8.ebuild
index 02cdfd9970b0..99ed556209d0 100644
--- a/net-irc/xchat/xchat-2.8.8.ebuild
+++ b/net-irc/xchat/xchat-2.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8.ebuild,v 1.3 2010/07/26 13:33:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8.ebuild,v 1.4 2010/07/28 11:27:43 polynomial-c Exp $
EAPI=2
@@ -41,7 +41,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-input-box3.patch
+ epatch "${FILESDIR}"/${PN}-input-box4.patch
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
# use libdir/xchat/plugins as the plugin directory