summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-15 12:13:28 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-15 12:13:28 +0000
commit906e8962fadbedf80e3e89393780475a6de8edb0 (patch)
tree784ee21a9800de8cd3715cbaaa7b76e31a478978 /net-irc
parentVersion bump, new build system, glibc2.20/werror issue (bug 528936) (diff)
downloadgentoo-2-906e8962fadbedf80e3e89393780475a6de8edb0.tar.gz
gentoo-2-906e8962fadbedf80e3e89393780475a6de8edb0.tar.bz2
gentoo-2-906e8962fadbedf80e3e89393780475a6de8edb0.zip
Fix building against sys-libs/ncurses[tinfo] (bug #528360). Fix CFLAGS mangling, resoect CC (bug #423835).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/tirc/ChangeLog10
-rw-r--r--net-irc/tirc/files/tirc-1.2-configure.patch30
-rw-r--r--net-irc/tirc/tirc-0.54_alpha.ebuild33
-rw-r--r--net-irc/tirc/tirc-1.2.ebuild11
4 files changed, 45 insertions, 39 deletions
diff --git a/net-irc/tirc/ChangeLog b/net-irc/tirc/ChangeLog
index 51b0cd6234c9..682a28161814 100644
--- a/net-irc/tirc/ChangeLog
+++ b/net-irc/tirc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/tirc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/tirc/ChangeLog,v 1.6 2013/03/30 14:43:52 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/tirc/ChangeLog,v 1.7 2014/11/15 12:13:28 jer Exp $
+
+ 15 Nov 2014; Jeroen Roovers <jer@gentoo.org> +files/tirc-1.2-configure.patch,
+ -tirc-0.54_alpha.ebuild, tirc-1.2.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #528360). Fix CFLAGS
+ mangling, resoect CC (bug #423835).
30 Mar 2013; Ulrich Müller <ulm@gentoo.org> tirc-0.54_alpha.ebuild:
Fix LICENSE, BSD according to COPYRIGHT file.
@@ -25,4 +30,3 @@
16 Jul 2004; Sven Wegener <swegener@gentoo.org> +metadata.xml,
+tirc-0.54_alpha.ebuild:
Initial import, ebuild written by me.
-
diff --git a/net-irc/tirc/files/tirc-1.2-configure.patch b/net-irc/tirc/files/tirc-1.2-configure.patch
new file mode 100644
index 000000000000..34cee9b6a5ef
--- /dev/null
+++ b/net-irc/tirc/files/tirc-1.2-configure.patch
@@ -0,0 +1,30 @@
+--- a/configure.in
++++ b/configure.in
+@@ -30,7 +30,6 @@
+ [tirc_cv_debug="yes"], [tirc_cv_debug="no"])
+ if test "$tirc_cv_debug" = yes; then
+ AC_DEFINE(DEBUGV)
+- OPTFLAG=${OPTFLAG-"-g"}
+ else
+ dnl Defining NDEBUG disables the assert() macro.
+ AC_DEFINE(NDEBUG)
+@@ -351,6 +350,10 @@
+ [tirc_cv_have_tparm=no])
+ fi
+ if test "$tirc_cv_have_tparm" = no; then
++ AC_CHECK_LIB(tinfo, tparm, [tirc_cv_have_tparm=tinfo],
++ [tirc_cv_have_tparm=no])
++fi
++if test "$tirc_cv_have_tparm" = no; then
+ AC_CHECK_LIB(curses, tparm, [tirc_cv_have_tparm=curses],
+ [tirc_cv_have_tparm=no])
+ fi
+@@ -715,7 +718,7 @@
+
+ dnl Get the optimization and debug stuff out of CFLAGS where the darn stupid
+ dnl autoconf dumps them into.
+-CFLAGS=`echo $CFLAGS | sed -e 's/-O.//' -e 's/-g//'`
++dnl CFLAGS=`echo $CFLAGS | sed -e 's/-O.//' -e 's/-g//'`
+
+ dnl Add efence if configured.
+ if test "$tirc_cv_efence" = yes; then
diff --git a/net-irc/tirc/tirc-0.54_alpha.ebuild b/net-irc/tirc/tirc-0.54_alpha.ebuild
deleted file mode 100644
index 10a6f63249ff..000000000000
--- a/net-irc/tirc/tirc-0.54_alpha.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/tirc/tirc-0.54_alpha.ebuild,v 1.3 2013/03/30 14:43:52 ulm Exp $
-
-MY_P=${P/_alpha/a}-patched
-
-DESCRIPTION="Token's IRC client"
-HOMEPAGE="http://home.mayn.de/jean-luc/alt/tirc/"
-SRC_URI="http://home.mayn.de/jean-luc/alt/tirc/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="debug"
-
-DEPEND="sys-libs/ncurses"
-
-S=${WORKDIR}/${PN}-alpha
-
-src_compile() {
- econf \
- --with-all \
- $(use_enable debug) \
- || die "econf failed"
- emake depend || die "emake depend failed"
- emake tirc || die "emake tirc failed"
-}
-
-src_install() {
- dobin tirc || die "dobin failed"
- doman tirc.1 || die "doman failed"
- dodoc COMMENT Changelog FAQ Notes README doc/* || die "dodoc failed"
-}
diff --git a/net-irc/tirc/tirc-1.2.ebuild b/net-irc/tirc/tirc-1.2.ebuild
index 9e21e04a676c..c92f72c54e31 100644
--- a/net-irc/tirc/tirc-1.2.ebuild
+++ b/net-irc/tirc/tirc-1.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/tirc/tirc-1.2.ebuild,v 1.2 2011/05/16 16:38:38 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/tirc/tirc-1.2.ebuild,v 1.3 2014/11/15 12:13:28 jer Exp $
-EAPI=4
+EAPI=5
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Token's IRC client"
HOMEPAGE="http://home.mayn.de/jean-luc/alt/tirc/"
@@ -19,9 +20,13 @@ RDEPEND="${DEPEND}"
src_prepare() {
# Don't call dodoc on a directory, bug #367505.
rm -rf doc/RCS || die
+
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
}
src_configure() {
+ tc-export CC
econf \
$(use_enable debug)
}