summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-12 14:25:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-12 14:25:50 +0000
commitae22835a39b705589baca32862f5661cea56a985 (patch)
treebd623305f8add9bac47ca8239ded796b7a45cc45 /net-irc
parentAvoid reporting pre-stripped file, prebuilt binary. (diff)
downloadgentoo-2-ae22835a39b705589baca32862f5661cea56a985.tar.gz
gentoo-2-ae22835a39b705589baca32862f5661cea56a985.tar.bz2
gentoo-2-ae22835a39b705589baca32862f5661cea56a985.zip
Version bump.
(Portage version: 13636-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/kvirc/ChangeLog8
-rw-r--r--net-irc/kvirc/kvirc-4.0_pre3244.ebuild86
-rw-r--r--net-irc/kvirc/kvirc-9999.ebuild13
3 files changed, 103 insertions, 4 deletions
diff --git a/net-irc/kvirc/ChangeLog b/net-irc/kvirc/ChangeLog
index 82c6d52aee62..3b52275205b6 100644
--- a/net-irc/kvirc/ChangeLog
+++ b/net-irc/kvirc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/kvirc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.83 2009/05/16 14:32:25 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.84 2009/06/12 14:25:50 arfrever Exp $
+
+*kvirc-4.0_pre3244 (12 Jun 2009)
+
+ 12 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +kvirc-4.0_pre3244.ebuild, kvirc-9999.ebuild:
+ Version bump.
16 May 2009; Mounir Lamouri <volkmar@gentoo.org> metadata.xml:
Use global gsm USE flag instead of local one.
diff --git a/net-irc/kvirc/kvirc-4.0_pre3244.ebuild b/net-irc/kvirc/kvirc-4.0_pre3244.ebuild
new file mode 100644
index 000000000000..81b4cb78c387
--- /dev/null
+++ b/net-irc/kvirc/kvirc-4.0_pre3244.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-4.0_pre3244.ebuild,v 1.1 2009/06/12 14:25:50 arfrever Exp $
+
+EAPI="2"
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Advanced IRC Client"
+HOMEPAGE="http://www.kvirc.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="kvirc"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="audiofile +crypt +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus qt-webkit +ssl +transparency"
+
+RDEPEND="
+ sys-libs/zlib
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ kde? ( >=kde-base/kdelibs-4 )
+ oss? ( audiofile? ( media-libs/audiofile ) )
+ perl? ( dev-lang/perl )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ python? ( dev-lang/python )
+ qt-dbus? ( x11-libs/qt-dbus )
+ qt-webkit? ( x11-libs/qt-webkit )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+RDEPEND="${RDEPEND}
+ gsm? ( media-sound/gsm )"
+
+DOCS="ChangeLog TODO"
+
+pkg_setup() {
+ if use audiofile && ! use oss; then
+ die "USE=\"audiofile\" requires USE=\"oss\""
+ fi
+}
+
+src_prepare() {
+ local VERSIO_PRAESENS="${PV#*_pre}"
+ elog "Setting revision number to ${VERSIO_PRAESENS}"
+ sed -e "/#define KVI_DEFAULT_FRAME_CAPTION/s/KVI_VERSION/& \" r${VERSIO_PRAESENS}\"/" -i src/kvirc/ui/kvi_frame.cpp || die "Failed to set revision number"
+}
+
+src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs="
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCOEXISTENCE=1
+ -DLIB_SUFFIX=${libdir#lib}
+ -DVERBOSE=1
+ $(cmake-utils_use_want audiofile AUDIOFILE)
+ $(cmake-utils_use_want crypt CRYPT)
+ $(cmake-utils_use_want dcc_voice DCC_VOICE)
+ $(cmake-utils_use_want debug DEBUG)
+ $(cmake-utils_use_want doc DOXYGEN)
+ $(cmake-utils_use_want gsm GSM)
+ $(cmake-utils_use_want ipc IPC)
+ $(cmake-utils_use_want ipv6 IPV6)
+ $(cmake-utils_use_want kde KDE4)
+ $(cmake-utils_use_want nls GETTEXT)
+ $(cmake-utils_use_want oss OSS)
+ $(cmake-utils_use_want perl PERL)
+ $(cmake-utils_use_want phonon PHONON)
+ $(cmake-utils_use_want profile MEMORY_PROFILE)
+ $(cmake-utils_use_want python PYTHON)
+ $(cmake-utils_use_want qt-dbus QTDBUS)
+ $(cmake-utils_use_want qt-webkit QTWEBKIT)
+ $(cmake-utils_use_want ssl OPENSSL)
+ $(cmake-utils_use_want transparency TRANSPARENCY)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}"usr/share/man/man1/kvirc.1 "${D}"usr/share/man/man1/kvirc4.1 || die "mv kvirc.1 failed"
+
+ elog "In order to keep KVIrc 4 and KVIrc3 working both side-by-side"
+ elog "man page for ${P} is under \"man kvirc4\""
+}
diff --git a/net-irc/kvirc/kvirc-9999.ebuild b/net-irc/kvirc/kvirc-9999.ebuild
index 82acceac96ea..c350616b02bf 100644
--- a/net-irc/kvirc/kvirc-9999.ebuild
+++ b/net-irc/kvirc/kvirc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.19 2009/03/29 23:27:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.20 2009/06/12 14:25:50 arfrever Exp $
EAPI="2"
@@ -15,14 +15,14 @@ ESVN_PROJECT="kvirc"
LICENSE="kvirc"
SLOT="4"
KEYWORDS=""
-IUSE="audiofile +crypt +dcc_voice debug doc gsm +ipc ipv6 kde +nls +perl +phonon profile +python +qt-dbus qt-webkit +ssl +transparency"
+IUSE="audiofile +crypt +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus qt-webkit +ssl +transparency"
RDEPEND="
sys-libs/zlib
x11-libs/qt-core
x11-libs/qt-gui
- audiofile? ( media-libs/audiofile )
kde? ( >=kde-base/kdelibs-4 )
+ oss? ( audiofile? ( media-libs/audiofile ) )
perl? ( dev-lang/perl )
phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
python? ( dev-lang/python )
@@ -37,6 +37,12 @@ RDEPEND="${RDEPEND}
DOCS="ChangeLog TODO"
+pkg_setup() {
+ if use audiofile && ! use oss; then
+ die "USE=\"audiofile\" requires USE=\"oss\""
+ fi
+}
+
src_prepare() {
subversion_wc_info
local VERSIO_PRAESENS="${ESVN_WC_REVISION}"
@@ -61,6 +67,7 @@ src_configure() {
$(cmake-utils_use_want ipv6 IPV6)
$(cmake-utils_use_want kde KDE4)
$(cmake-utils_use_want nls GETTEXT)
+ $(cmake-utils_use_want oss OSS)
$(cmake-utils_use_want perl PERL)
$(cmake-utils_use_want phonon PHONON)
$(cmake-utils_use_want profile MEMORY_PROFILE)