summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-16 16:19:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-16 16:19:11 +0000
commitc53638be4399438a9d14d5d7c3d023fc2c3c3616 (patch)
treeea1ce1918285004ea543fca03bf933fa42903ac7 /net-irc
parentMarking apache-2.2.9 ppc64 for bug 227111 (diff)
downloadgentoo-2-c53638be4399438a9d14d5d7c3d023fc2c3c3616.tar.gz
gentoo-2-c53638be4399438a9d14d5d7c3d023fc2c3c3616.tar.bz2
gentoo-2-c53638be4399438a9d14d5d7c3d023fc2c3c3616.zip
New revision of the live ebuild. Upstream switched to cmake, so let's follow with the ebuild too.
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog9
-rw-r--r--net-irc/quassel/quassel-9999-r1.ebuild (renamed from net-irc/quassel/quassel-9999.ebuild)41
2 files changed, 31 insertions, 19 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 123f85454e8a..c62741701154 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.15 2008/06/03 15:04:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.16 2008/06/16 16:19:11 flameeyes Exp $
+
+*quassel-9999-r1 (16 Jun 2008)
+
+ 16 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> -quassel-9999.ebuild,
+ +quassel-9999-r1.ebuild:
+ New revision of the live ebuild. Upstream switched to cmake, so let's
+ follow with the ebuild too.
03 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> quassel-9999.ebuild:
Update live ebuild to use GIT rather than Subversion, as upstream switched
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999-r1.ebuild
index d560c214089e..d44bc3e03dbf 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999-r1.ebuild
@@ -1,14 +1,19 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.5 2008/06/03 15:04:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999-r1.ebuild,v 1.1 2008/06/16 16:19:11 flameeyes Exp $
EAPI=1
-inherit qt4
+inherit cmake-utils
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git
EGIT_REPO_URI="git://git.quassel-irc.org/quassel.git"
+
+ case ${PV} in
+ 0.2.9999) EGIT_BRANCH="0.2" ;;
+ *) EGIT_BRANCH="master"
+ esac
else
MY_P="${P/_/-}"
SRC_URI="http://quassel-irc.org/system/files/${MY_P}.tar.bz2"
@@ -39,6 +44,8 @@ RDEPEND="|| (
)"
DEPEND="${RDEPEND}"
+DOCS="ChangeLog README README.Qtopia"
+
pkg_setup() {
if ! use server && ! use X; then
eerror "You have to build one or both of quassel client or server."
@@ -59,26 +66,24 @@ pkg_setup() {
}
src_compile() {
- local BUILD=""
- use server && BUILD="${BUILD} core"
- use X && BUILD="${BUILD} qtclient"
+ local mycmakeargs="
+ $(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want X QTCLIENT)
+ -DWANT_MONO=OFF
+ "
- eqmake4 ${PN}.pro BUILD="${BUILD}" || die "eqmake4 failed"
- emake || die "emake failed"
+ cmake-utils_src_compile
}
src_install() {
- local targets=""
- use server && targets="${targets} build/targets/quasselcore"
- use X && targets="${targets} build/targets/quasselclient"
- dobin $targets || die "quasselcore install failed"
+ cmake-utils_src_install
- # Only install the desktop file if the X client was installed
+ # Only install the icons if the X client was installed
if use X; then
- sed -i -e 's:Exec=quassel:Exec=quasselclient:' ${PN}.desktop \
- || die "failed to fix desktop file"
- domenu ${PN}.desktop || die "desktop file install failed"
+ local size
+ for size in 16 24 32 48 64 96 128 256 512; do
+ insinto /usr/share/icons/hicolor/${size}x${size}
+ newins "${S}"/src/icons/quassel/connected/${size}.png quassel.png
+ done
fi
-
- dodoc ChangeLog README README.Qtopia || "dodoc failed"
}