summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-21 23:35:35 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-21 23:35:35 +0000
commit2d8189320b3de4e16ec1712b18d10dcdead1e1ca (patch)
treedec9544821b7ae334f0bfb68b46cb108465ef59d /net-libs/cyassl
parentInherit eutils for epatch, use $(usex), and display configure commands. (diff)
downloadgentoo-2-2d8189320b3de4e16ec1712b18d10dcdead1e1ca.tar.gz
gentoo-2-2d8189320b3de4e16ec1712b18d10dcdead1e1ca.tar.bz2
gentoo-2-2d8189320b3de4e16ec1712b18d10dcdead1e1ca.zip
Version bump to 2.2 branch
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/cyassl')
-rw-r--r--net-libs/cyassl/ChangeLog8
-rw-r--r--net-libs/cyassl/cyassl-2.2.0.ebuild105
-rw-r--r--net-libs/cyassl/metadata.xml2
3 files changed, 114 insertions, 1 deletions
diff --git a/net-libs/cyassl/ChangeLog b/net-libs/cyassl/ChangeLog
index 6b70be59a463..a7821ed0c20b 100644
--- a/net-libs/cyassl/ChangeLog
+++ b/net-libs/cyassl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/cyassl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.1 2012/04/11 01:58:09 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.2 2012/05/21 23:35:35 blueness Exp $
+
+*cyassl-2.2.0 (21 May 2012)
+
+ 21 May 2012; Anthony G. Basile <blueness@gentoo.org> +cyassl-2.2.0.ebuild,
+ metadata.xml:
+ Version bump to 2.2 branch
*cyassl-2.0.8 (11 Apr 2012)
diff --git a/net-libs/cyassl/cyassl-2.2.0.ebuild b/net-libs/cyassl/cyassl-2.2.0.ebuild
new file mode 100644
index 000000000000..cb87eca3fc72
--- /dev/null
+++ b/net-libs/cyassl/cyassl-2.2.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.2.0.ebuild,v 1.1 2012/05/21 23:35:35 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
+HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
+SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#Add CRYPTO_OPTS=ecc when fixed
+CACHE_SIZE="small big +huge"
+CRYPTO_OPTS="aes-ni +hc128 +psk +ripemd sha512"
+CERT_OPTS="ocsp crl +sessioncerts +testcert"
+IUSE="-dtls ipv6 +httpd +sniffer static-libs threads +zlib cyassl-hardening ${CACHE_SIZE} ${CRYPTO_OPTS} ${CERT_OPTS}"
+
+#You can only pick one cach size
+#sha512 is broken on x86
+#Testing freezes with dtls
+REQUIRED_USE="^^ ( small big huge )
+ x86? ( !sha512 )
+ test? ( !dtls )"
+
+DEPEND="sniffer? ( net-libs/libpcap )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.8-disable-testsuit-ifnothreads.patch
+
+ #Apply unconditionally, but only triggered if USE="aes-ni"
+ epatch "${FILESDIR}"/${PN}-2.0.8-fix-gnustack.patch
+}
+
+src_configure() {
+ local myconf=()
+
+ if use threads; then
+ myconf+=( --disable-singleThreaded )
+ else
+ myconf+=( --enable-singleThreaded )
+ fi
+
+ if use amd64; then
+ myconf+=( --enable-fastmath --enable-fasthugemath --enable-bump )
+ elif use x86; then
+ #not pie friendly, sorry x86, no fast math for you :(
+ myconf+=( --disable-fastmath --disable-fasthugemath --disable-bump )
+ fi
+
+ #There are lots of options, so we'll force a few reasonable
+ #We may change this in the future, in particular ecc needs to be fixed
+ econf \
+ --enable-opensslExtra \
+ --enable-fortress \
+ --enable-keygen \
+ --enable-certgen \
+ --disable-debug \
+ --disable-ecc \
+ --disable-small \
+ --disable-ntru \
+ --disable-noFilesystem \
+ --disable-noInline \
+ --disable-gcc-lots-o-warnings \
+ $(use_enable small smallcache) \
+ $(use_enable big bigcache) \
+ $(use_enable huge hugecache) \
+ $(use_enable aes-ni aesni) \
+ $(use_enable hc128) \
+ $(use_enable psk) \
+ $(use_enable ripemd) \
+ $(use_enable sha512) \
+ $(use_enable dtls) \
+ $(use_enable ipv6) \
+ $(use_enable httpd webServer) \
+ $(use_enable ocsp) \
+ $(use_enable crl) \
+ $(use_enable sessioncerts) \
+ $(use_enable sniffer) \
+ $(use_enable testcert) \
+ $(use_enable static-libs static) \
+ $(use_enable cyassl-hardening gcc-hardening) \
+ $(use_enable cyassl-hardening linker-hardening) \
+ $(use_with zlib libz) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ "${S}"/tests/unit
+ "${S}"/ctaocrypt/benchmark/benchmark
+}
+
+src_install() {
+ default
+
+ mv "${D}"/usr/share/doc/"${PN}"/* \
+ "${D}"/usr/share/doc/"${P}"/
+ rmdir "${D}"/usr/share/doc/"${PN}"/
+}
diff --git a/net-libs/cyassl/metadata.xml b/net-libs/cyassl/metadata.xml
index 01a71453e8c8..9a903b105bdb 100644
--- a/net-libs/cyassl/metadata.xml
+++ b/net-libs/cyassl/metadata.xml
@@ -19,6 +19,8 @@
<flag name="huge">Choose big cache size (excludes small or big)</flag>
<flag name="dtls">Enable datagram TLS</flag>
<flag name="httpd">Enable features for yaSSL web server</flag>
+ <flag name="ocsp">Enable Online Certificate Status Protocol</flag>
+ <flag name="crl">Enable Certificate Revocation List</flag>
<flag name="sessioncerts">Store session certificates</flag>
<flag name="sniffer">Allow collection/decryption of SSL traffic</flag>
<flag name="sniffer">Allow collection/decryption of SSL traffic</flag>