summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-01-05 12:16:04 +0000
committerMichael Weber <xmw@gentoo.org>2012-01-05 12:16:04 +0000
commit2079b00419bc56afeb04b3c9e62ac6794ad55bea (patch)
tree1a081c09c039290b83968805c3ba6e2578190058 /net-libs/enet/enet-1.3.3.ebuild
parentBump to 1.0.0, bug 396273. Thanks to Nikoli for patch (diff)
downloadgentoo-2-2079b00419bc56afeb04b3c9e62ac6794ad55bea.tar.gz
gentoo-2-2079b00419bc56afeb04b3c9e62ac6794ad55bea.tar.bz2
gentoo-2-2079b00419bc56afeb04b3c9e62ac6794ad55bea.zip
Versio bump (thanks Dennis Schridde for the report, bug 375037)
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/enet/enet-1.3.3.ebuild')
-rw-r--r--net-libs/enet/enet-1.3.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/enet/enet-1.3.3.ebuild b/net-libs/enet/enet-1.3.3.ebuild
new file mode 100644
index 000000000000..af251069ce46
--- /dev/null
+++ b/net-libs/enet/enet-1.3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.3.3.ebuild,v 1.1 2012/01/05 12:16:04 xmw Exp $
+
+EAPI=3
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}