summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-06-29 12:08:23 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-06-29 12:08:23 +0000
commitb56acaa81b62934556297a280544fd14b62d0f53 (patch)
tree1779251c595ae35662364af099e6771ce4efbbba /net-libs/gloox
parentcleanup for wrt bug 515636 (diff)
downloadgentoo-2-b56acaa81b62934556297a280544fd14b62d0f53.tar.gz
gentoo-2-b56acaa81b62934556297a280544fd14b62d0f53.tar.bz2
gentoo-2-b56acaa81b62934556297a280544fd14b62d0f53.zip
Revision bump: add support for user patches, do not build examples, prune unneeded libtool files, conditionally build static library, set proper condition on debug builds, build tests only when it's needed. Drop old revision
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/ChangeLog11
-rw-r--r--net-libs/gloox/gloox-1.0.10-r1.ebuild (renamed from net-libs/gloox/gloox-1.0.10.ebuild)27
2 files changed, 29 insertions, 9 deletions
diff --git a/net-libs/gloox/ChangeLog b/net-libs/gloox/ChangeLog
index 1138b9e0c9a9..915e1f9fe8f7 100644
--- a/net-libs/gloox/ChangeLog
+++ b/net-libs/gloox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/gloox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.23 2014/06/29 11:15:19 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.24 2014/06/29 12:08:23 pinkbyte Exp $
+
+*gloox-1.0.10-r1 (29 Jun 2014)
+
+ 29 Jun 2014; Sergey Popov <pinkbyte@gentoo.org> -gloox-1.0.10.ebuild,
+ +gloox-1.0.10-r1.ebuild:
+ Revision bump: add support for user patches, do not build examples, prune
+ unneeded libtool files, conditionally build static library, set proper
+ condition on debug builds, build tests only when it's needed. Drop old
+ revision
29 Jun 2014; Sergey Popov <pinkbyte@gentoo.org> gloox-1.0.9.ebuild:
Stable on x86, wrt bug #495850
diff --git a/net-libs/gloox/gloox-1.0.10.ebuild b/net-libs/gloox/gloox-1.0.10-r1.ebuild
index 7fd9e2802c6b..aea8d5cdfd54 100644
--- a/net-libs/gloox/gloox-1.0.10.ebuild
+++ b/net-libs/gloox/gloox-1.0.10-r1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.10.ebuild,v 1.2 2014/06/20 12:33:51 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.10-r1.ebuild,v 1.1 2014/06/29 12:08:23 pinkbyte Exp $
EAPI=5
-MY_P=${P/_/-}
+inherit eutils
+
+MY_P="${P/_/-}"
DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
HOMEPAGE="http://camaya.net/gloox"
SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
@@ -12,7 +14,7 @@ SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~x86"
-IUSE="debug gnutls idn ssl zlib"
+IUSE="debug gnutls idn ssl static-libs test zlib"
DEPEND="idn? ( net-dns/libidn )
gnutls? ( net-libs/gnutls )
@@ -21,17 +23,26 @@ DEPEND="idn? ( net-dns/libidn )
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch_user
+}
src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
econf \
- $(use_enable debug debug) \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
$(use_with idn libidn) \
- $(use_with gnutls gnutls) \
+ $(use_with gnutls) \
$(use_with ssl openssl) \
- $(use_with zlib zlib)
+ $(use_with test tests) \
+ $(use_with zlib)
}
src_install() {
- emake DESTDIR="${D}" install
+ default
+ prune_libtool_files
}