summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-03 06:35:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-03 06:35:29 +0000
commit3d639209ac963321595a5ad41aada6ebb9ab45c4 (patch)
tree75ba81d07a7aaaef08dd75f4bd9e1875fd489de5 /net-libs/gsoap/gsoap-2.7.9f.ebuild
parentFix metadata.xml (diff)
downloadgentoo-2-3d639209ac963321595a5ad41aada6ebb9ab45c4.tar.gz
gentoo-2-3d639209ac963321595a5ad41aada6ebb9ab45c4.tar.bz2
gentoo-2-3d639209ac963321595a5ad41aada6ebb9ab45c4.zip
Initial Import from jokey overlay. Dep of newer virtualbox-ose. Ebuilds by Alessio Cassibba.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gsoap/gsoap-2.7.9f.ebuild')
-rw-r--r--net-libs/gsoap/gsoap-2.7.9f.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/gsoap/gsoap-2.7.9f.ebuild b/net-libs/gsoap/gsoap-2.7.9f.ebuild
new file mode 100644
index 000000000000..494f031d2a89
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.7.9f.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.7.9f.ebuild,v 1.1 2009/03/03 06:35:29 patrick Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_P="${PN}-2.7"
+DESCRIPTION="A cross-platfor open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.tar.gz"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug +ssl"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf $(use_enable ssl openssl) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 install || die "Install failed"
+
+ dodir /usr/share/doc/${P}
+ dodoc NOTES.txt README.txt
+ dohtml changelog.html
+
+ if use doc; then
+ dohtml -r gsoap/doc/
+ fi
+}