summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-09-15 20:44:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-09-15 20:44:06 +0000
commitabf7935b1b04386c76acb459a58b2396dad20845 (patch)
tree18daf1b6ad840949363f23b33e29108096fba44e /net-libs/gupnp-igd
parentFix build with zlib-1.2.5.1 (bug #383113, patch by Nikos Chantziaras). (diff)
downloadgentoo-2-abf7935b1b04386c76acb459a58b2396dad20845.tar.gz
gentoo-2-abf7935b1b04386c76acb459a58b2396dad20845.tar.bz2
gentoo-2-abf7935b1b04386c76acb459a58b2396dad20845.zip
Version bump. Add introspection support.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gupnp-igd')
-rw-r--r--net-libs/gupnp-igd/ChangeLog8
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.1.10.ebuild104
-rw-r--r--net-libs/gupnp-igd/metadata.xml4
3 files changed, 115 insertions, 1 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index 7182a879ec55..1fd6d0ad57fa 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.27 2011/02/26 20:02:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.28 2011/09/15 20:44:06 eva Exp $
+
+*gupnp-igd-0.1.10 (15 Sep 2011)
+
+ 15 Sep 2011; Gilles Dartiguelongue <eva@gentoo.org> +gupnp-igd-0.1.10.ebuild,
+ metadata.xml:
+ Version bump. Add introspection support.
26 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gupnp-igd-0.1.7.ebuild, +files/gupnp-igd-0.1.7-disable_static_modules.patch:
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.1.10.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.1.10.ebuild
new file mode 100644
index 000000000000..1822aa508838
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.1.10.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.1.10.ebuild,v 1.1 2011/09/15 20:44:06 eva Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit autotools eutils python
+
+DESCRIPTION="This is a library to handle UPnP IGD port mapping for GUPnP."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://www.gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection python"
+
+RDEPEND=">=net-libs/gupnp-0.13.2
+ >=dev-libs/glib-2.16:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+ python? ( >=dev-python/pygobject-2.16 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/gtk-doc-am"
+
+# The only existing test is broken
+RESTRICT="test"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.1.7-disable_static_modules.patch
+
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ # Python bindings are built/installed manually.
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_compile() {
+ # introspection is built in the same directory and libtool does not handle
+ # well dependency like this
+ MAKEOPTS="${MAKEOPTS} -j1" default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+
+ dodoc AUTHORS NEWS README TODO || die
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize gupnp
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup gupnp
+ fi
+}
diff --git a/net-libs/gupnp-igd/metadata.xml b/net-libs/gupnp-igd/metadata.xml
index 7289824cb876..bcf095d10035 100644
--- a/net-libs/gupnp-igd/metadata.xml
+++ b/net-libs/gupnp-igd/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-p2p</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
+ </use>
</pkgmetadata>