summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-02 15:57:55 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-02 15:57:55 +0000
commit07c9f3823aa801ebf6caf1aae4c3254a5bd070b3 (patch)
tree2c5748c1d8abcf7f173c3e4f31730a48e1e13d85 /net-libs/ldns
parentbump to EAPI=4 (diff)
downloadgentoo-2-07c9f3823aa801ebf6caf1aae4c3254a5bd070b3.tar.gz
gentoo-2-07c9f3823aa801ebf6caf1aae4c3254a5bd070b3.tar.bz2
gentoo-2-07c9f3823aa801ebf6caf1aae4c3254a5bd070b3.zip
Revert -r1 change (inclusion of /usr/bin/drill). Add elog about it.
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/ChangeLog7
-rw-r--r--net-libs/ldns/ldns-1.6.12-r2.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-libs/ldns/ChangeLog b/net-libs/ldns/ChangeLog
index 3eae05f14ec4..6e1e271f140b 100644
--- a/net-libs/ldns/ChangeLog
+++ b/net-libs/ldns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ldns
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.26 2012/05/31 05:43:56 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.27 2012/06/02 15:57:55 xmw Exp $
+
+*ldns-1.6.12-r2 (02 Jun 2012)
+
+ 02 Jun 2012; Michael Weber <xmw@gentoo.org> +ldns-1.6.12-r2.ebuild:
+ Revert -r1 change (inclusion of /usr/bin/drill). Add elog about it.
*ldns-1.6.12-r1 (31 May 2012)
diff --git a/net-libs/ldns/ldns-1.6.12-r2.ebuild b/net-libs/ldns/ldns-1.6.12-r2.ebuild
new file mode 100644
index 000000000000..f63c283843f8
--- /dev/null
+++ b/net-libs/ldns/ldns-1.6.12-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.12-r2.ebuild,v 1.1 2012/06/02 15:57:55 xmw Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit autotools eutils python
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+IUSE="doc examples gost python ssl static-libs vim-syntax"
+
+RESTRICT="test" # 1.6.9 has no test directory
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7 )
+ gost? ( >=dev-libs/openssl-1 )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/1.6.12-cflags.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with examples) \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_enable static-libs static) \
+ $(use_with ssl) \
+ $(use_with python pyldns) \
+ $(use_with python pyldnsx) \
+ --without-drill \
+ --disable-rpath
+}
+
+src_compile() {
+ emake
+ if use doc ; then
+ emake doxygen
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc Changelog README*
+
+ if use python ; then
+ find "${ED}$(python_get_sitedir)" "(" -name "*.a" -o -name "*.la" ")" -type f -delete || die
+ fi
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ if use doc ; then
+ dohtml doc/html/*
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim
+ fi
+
+ einfo
+ elog "Install net-dns/ldns-utils if you want drill"
+ einfo
+}