summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-15 17:58:17 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-15 17:58:17 +0000
commit5a84b7bfd1ed6ed4b1428b9c2879da27d4ac0be9 (patch)
treee8dc4dfc919de847dec6401722eebf7e6068e353 /net-libs/libnet
parentFix building against net-libs/libnet-1.2 / remove unneeded version test. (diff)
downloadgentoo-2-5a84b7bfd1ed6ed4b1428b9c2879da27d4ac0be9.tar.gz
gentoo-2-5a84b7bfd1ed6ed4b1428b9c2879da27d4ac0be9.tar.bz2
gentoo-2-5a84b7bfd1ed6ed4b1428b9c2879da27d4ac0be9.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs/libnet')
-rw-r--r--net-libs/libnet/ChangeLog7
-rw-r--r--net-libs/libnet/libnet-1.2_rc1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index 296a444607c2..849879e758b1 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.99 2013/02/19 05:00:03 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.100 2013/03/15 17:58:17 jer Exp $
+
+*libnet-1.2_rc1 (15 Mar 2013)
+
+ 15 Mar 2013; Jeroen Roovers <jer@gentoo.org> +libnet-1.2_rc1.ebuild:
+ Version bump.
19 Feb 2013; Zac Medico <zmedico@gentoo.org> libnet-1.1.6.ebuild:
Add ~arm-linux keyword.
diff --git a/net-libs/libnet/libnet-1.2_rc1.ebuild b/net-libs/libnet/libnet-1.2_rc1.ebuild
new file mode 100644
index 000000000000..a22bb8b2c631
--- /dev/null
+++ b/net-libs/libnet/libnet-1.2_rc1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.2_rc1.ebuild,v 1.1 2013/03/15 17:58:17 jer Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
+HOMEPAGE="http://libnet-dev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}-dev/${P/_/-}.tar.gz"
+
+LICENSE="BSD BSD-2 HPND"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc static-libs"
+
+DEPEND="sys-devel/autoconf"
+RDEPEND=""
+
+DOCS=(
+ README doc/{CHANGELOG,CONTRIB,DESIGN_NOTES,MIGRATION}
+ doc/{PACKET_BUILDING,PORTED,RAWSOCKET_NON_SEQUITUR,TODO}
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ docinto sample
+ dodoc sample/*.[ch]
+ fi
+
+ use static-libs || prune_libtool_files
+}