summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-21 04:12:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-21 04:12:16 +0000
commitb0ea0b27f54e9313711194410af3ecbb61d30fd1 (patch)
treeea58f0aa9b38823ef75d6eed5bf2476fbc8fc755 /net-libs/libnids/libnids-1.17_rc1.ebuild
parentdeprecate libnet-1.0.x (diff)
downloadgentoo-2-b0ea0b27f54e9313711194410af3ecbb61d30fd1.tar.gz
gentoo-2-b0ea0b27f54e9313711194410af3ecbb61d30fd1.tar.bz2
gentoo-2-b0ea0b27f54e9313711194410af3ecbb61d30fd1.zip
version bump
Diffstat (limited to 'net-libs/libnids/libnids-1.17_rc1.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.17_rc1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/libnids/libnids-1.17_rc1.ebuild b/net-libs/libnids/libnids-1.17_rc1.ebuild
new file mode 100644
index 000000000000..b1efc747b2f3
--- /dev/null
+++ b/net-libs/libnids/libnids-1.17_rc1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.17_rc1.ebuild,v 1.1 2003/08/21 04:12:16 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="emulates the IP stack of Linux 2.0.x and offers IP defragmentation, TCP stream assembly and TCP port scan detection."
+HOMEPAGE="http://www.packetfactory.net/Projects/libnids/"
+SRC_URI="http://www.packetfactory.net/Projects/libnids/dist/${P/_}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+S=${WORKDIR}/${P/_rc1}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/libnids_gcc33_fix
+}
+
+src_compile() {
+ econf || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc CHANGES COPYING CREDITS MISC README
+}