summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-05 23:37:08 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-05 23:37:08 +0000
commit531e07c8f11907eaf9ef5a7b63a1830d0ac983c1 (patch)
treeb94dbdd4ddfd4ebf332801efcff2cff980f72d72 /net-libs/libosmocore
parentVersion bump. (diff)
downloadgentoo-2-531e07c8f11907eaf9ef5a7b63a1830d0ac983c1.tar.gz
gentoo-2-531e07c8f11907eaf9ef5a7b63a1830d0ac983c1.tar.bz2
gentoo-2-531e07c8f11907eaf9ef5a7b63a1830d0ac983c1.zip
Version bump.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libosmocore')
-rw-r--r--net-libs/libosmocore/ChangeLog8
-rw-r--r--net-libs/libosmocore/libosmocore-0.5.2.ebuild41
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild5
3 files changed, 50 insertions, 4 deletions
diff --git a/net-libs/libosmocore/ChangeLog b/net-libs/libosmocore/ChangeLog
index 0c9958bf6b74..f6c8f5fee66f 100644
--- a/net-libs/libosmocore/ChangeLog
+++ b/net-libs/libosmocore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libosmocore
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.2 2012/07/05 21:41:57 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.3 2012/07/05 23:37:08 chithanh Exp $
+
+*libosmocore-0.5.2 (05 Jul 2012)
+
+ 05 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libosmocore-0.5.2.ebuild, libosmocore-9999.ebuild:
+ Version bump.
05 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> metadata.xml:
Assign maintainership to radio herd.
diff --git a/net-libs/libosmocore/libosmocore-0.5.2.ebuild b/net-libs/libosmocore/libosmocore-0.5.2.ebuild
new file mode 100644
index 000000000000..02f8ccaf01fc
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.5.2.ebuild,v 1.1 2012/07/05 23:37:08 chithanh Exp $
+
+EAPI="4"
+inherit autotools
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="embedded"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable embedded)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
index f6248abfbf78..54da8cf478b1 100644
--- a/net-libs/libosmocore/libosmocore-9999.ebuild
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.1 2012/06/15 13:51:23 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.2 2012/07/05 23:37:08 chithanh Exp $
EAPI="4"
inherit autotools
@@ -37,6 +37,5 @@ src_configure() {
src_install() {
default
# install to correct documentation directory
- mv "${ED}"/usr/share/doc/${PN}/${PN}-* "${ED}"/usr/share/doc/${PF} || die
- rmdir "${ED}"/usr/share/doc/${PN}/ || die
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
}