summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-02 05:58:19 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-02 05:58:19 +0000
commit618d0a127242763d2adf0b6ff6972e0cc32cd43e (patch)
treef80121d32a11682d15aa48fc978b4ad7e23b94fa /net-libs/libpcap
parentVersion bump for dev channel release. (diff)
downloadgentoo-2-618d0a127242763d2adf0b6ff6972e0cc32cd43e.tar.gz
gentoo-2-618d0a127242763d2adf0b6ff6972e0cc32cd43e.tar.bz2
gentoo-2-618d0a127242763d2adf0b6ff6972e0cc32cd43e.zip
Version bump, bug #312337, thank Richard Hartmann for report. Fixes compatibility issue with autoconf-2.64, bug #281690, dropped Mike's patch for that.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/ChangeLog10
-rw-r--r--net-libs/libpcap/files/libpcap-1.1-cross-linux.patch30
-rw-r--r--net-libs/libpcap/libpcap-1.1.0.ebuild57
3 files changed, 96 insertions, 1 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index 8d2280d40ff6..58ec134f7ea4 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.134 2010/02/25 21:13:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.135 2010/04/02 05:58:19 pva Exp $
+
+*libpcap-1.1.0 (02 Apr 2010)
+
+ 02 Apr 2010; Peter Volkov <pva@gentoo.org> +libpcap-1.1.0.ebuild,
+ +files/libpcap-1.1-cross-linux.patch:
+ Version bump, bug #312337, thank Richard Hartmann for report. Fixes
+ compatibility issue with autoconf-2.64, bug #281690, dropped Mike's patch
+ for that.
25 Feb 2010; Fabian Groffen <grobian@gentoo.org>
libpcap-1.0.1_pre20090812.ebuild:
diff --git a/net-libs/libpcap/files/libpcap-1.1-cross-linux.patch b/net-libs/libpcap/files/libpcap-1.1-cross-linux.patch
new file mode 100644
index 000000000000..5a35a89022d6
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.1-cross-linux.patch
@@ -0,0 +1,30 @@
+=== modified file 'configure.in'
+--- configure.in 2010-04-02 04:52:17 +0000
++++ configure.in 2010-04-02 04:52:22 +0000
+@@ -291,7 +291,12 @@
+ dnl XXX This could be done for cross-compiling, but for now it's not.
+ dnl
+ if test -z "$with_pcap" && test "$cross_compiling" = yes; then
+- AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...)
++ if test -z "$with_pcap" ; then
++ case $host in
++ *-linux*) with_pcap="linux";;
++ *) AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...);;
++ esac
++ fi
+ fi
+ AC_ARG_WITH(pcap,
+ AC_HELP_STRING([--with-pcap=TYPE],[use packet capture TYPE]))
+@@ -412,8 +417,10 @@
+ linux)
+ AC_MSG_CHECKING(Linux kernel version)
+ if test "$cross_compiling" = yes; then
++ dnl we could check linux/version.h here, but who runs
++ dnl versions of linux older than 2.0.x anymore to bother ?
+ AC_CACHE_VAL(ac_cv_linux_vers,
+- ac_cv_linux_vers=unknown)
++ ac_cv_linux_vers=2)
+ else
+ AC_CACHE_VAL(ac_cv_linux_vers,
+ ac_cv_linux_vers=`uname -r 2>&1 | \
+
diff --git a/net-libs/libpcap/libpcap-1.1.0.ebuild b/net-libs/libpcap/libpcap-1.1.0.ebuild
new file mode 100644
index 000000000000..8772c5a1998c
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.1.0.ebuild,v 1.1 2010/04/02 05:58:19 pva Exp $
+
+EAPI=2
+inherit autotools versionator eutils multilib toolchain-funcs
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth ipv6 libnl"
+
+RDEPEND="!virtual/libpcap
+ bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
+ libnl? ( dev-libs/libnl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+PROVIDE="virtual/libpcap"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1-cross-linux.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable ipv6) \
+ $(use_with libnl) \
+ $(use_enable bluetooth)
+}
+
+src_compile() {
+ emake all shared || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-shared || die "emake install failed"
+
+ dosym libpcap$(get_libname ${PV}) /usr/$(get_libdir)/libpcap$(get_libname 1)
+ dosym libpcap$(get_libname ${PV}) /usr/$(get_libdir)/libpcap$(get_libname)
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h || die "failed to install pcap-int.h"
+ fi
+
+ # We are not installing README.{Win32,aix,hpux,tru64} (bug 183057)
+ dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} || die
+}