summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-16 08:04:33 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-16 08:04:33 +0000
commit5d82b50152283afa958df358af0a59a224bfce97 (patch)
tree87faa94cd8ecce70045430c07c0c658b7f5b1981 /net-libs/libproxy
parentMask libproxy[spidermonkey] since spidermonkey is not keyworded on ia64 (diff)
downloadgentoo-2-5d82b50152283afa958df358af0a59a224bfce97.tar.gz
gentoo-2-5d82b50152283afa958df358af0a59a224bfce97.tar.bz2
gentoo-2-5d82b50152283afa958df358af0a59a224bfce97.zip
Version bump; fixes buffer overflow (bug #438146, CVE-2012-4504, thanks to Agostino Sarubbo). Re-add USE=webkit since it now works correctly (bug #412573, thanks to Lucian Muresan) and it enable by default to provide PAC and WPAD support. Alternatively, spidermonkey could be used for PAC instead (but might lead to firefox crashes, see bug #373397). Update license.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libproxy')
-rw-r--r--net-libs/libproxy/ChangeLog14
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch29
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.10-mozjs185.pc.patch25
-rw-r--r--net-libs/libproxy/libproxy-0.4.10.ebuild80
-rw-r--r--net-libs/libproxy/libproxy-0.4.6-r3.ebuild4
-rw-r--r--net-libs/libproxy/libproxy-0.4.7.ebuild4
-rw-r--r--net-libs/libproxy/metadata.xml6
7 files changed, 157 insertions, 5 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 429ac1bbadfe..dbb7c0fe451e 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.79 2012/05/26 08:57:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.80 2012/10/16 08:04:33 tetromino Exp $
+
+*libproxy-0.4.10 (16 Oct 2012)
+
+ 16 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libproxy-0.4.6-r3.ebuild, libproxy-0.4.7.ebuild, +libproxy-0.4.10.ebuild,
+ +files/libproxy-0.4.10-disable-pac-test.patch,
+ +files/libproxy-0.4.10-mozjs185.pc.patch, metadata.xml:
+ Version bump; fixes buffer overflow (bug #438146, CVE-2012-4504, thanks to
+ Agostino Sarubbo). Re-add USE=webkit since it now works correctly (bug
+ #412573, thanks to Lucian Muresan) and it enable by default to provide PAC
+ and WPAD support. Alternatively, spidermonkey could be used for PAC instead
+ (but might lead to firefox crashes, see bug #373397). Update license.
26 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
libproxy-0.4.7.ebuild, +files/libproxy-0.4.7-gcc-4.7.patch:
diff --git a/net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch b/net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch
new file mode 100644
index 000000000000..91658574134e
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch
@@ -0,0 +1,29 @@
+From 5a1a8d2b920006e54d9de971999b443073f50843 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 16 Oct 2012 03:30:50 -0400
+Subject: [PATCH] Disable PAC test
+
+get-pac-test freezes when run from the ebuild, but succeeds when
+building manually. Using Xemake/virtualx.eclass doesn't seem to help.
+---
+ libproxy/test/CMakeLists.txt | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/libproxy/test/CMakeLists.txt b/libproxy/test/CMakeLists.txt
+index 8894425..69543a4 100644
+--- a/libproxy/test/CMakeLists.txt
++++ b/libproxy/test/CMakeLists.txt
+@@ -17,10 +17,3 @@ if(WIN32)
+ target_link_libraries(url-encode ws2_32)
+ endif()
+ add_test(NAME url-encode COMMAND ${CMAKE_CURRENT_BINARY_DIR}/url-encode)
+-
+-# Get PAC
+-if (NOT WIN32)
+-add_executable(get-pac-test ${CMAKE_CURRENT_SOURCE_DIR}/get-pac-test.cpp ${PROJECT_SOURCE_DIR}/url.cpp)
+-target_link_libraries(get-pac-test pthread)
+-add_test(NAME get-pac-test COMMAND ${CMAKE_CURRENT_BINARY_DIR}/get-pac-test)
+-endif()
+--
+1.7.12.3
+
diff --git a/net-libs/libproxy/files/libproxy-0.4.10-mozjs185.pc.patch b/net-libs/libproxy/files/libproxy-0.4.10-mozjs185.pc.patch
new file mode 100644
index 000000000000..1ccbdd4e2a2f
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.10-mozjs185.pc.patch
@@ -0,0 +1,25 @@
+From dd09f546f0287cfeae587c723c98f70f3de65ab8 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 16 Oct 2012 03:03:48 -0400
+Subject: [PATCH] Gentoo's mozjs185.pc doesn't set Version:
+
+---
+ libproxy/cmake/modules/pacrunner_mozjs.cmk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libproxy/cmake/modules/pacrunner_mozjs.cmk b/libproxy/cmake/modules/pacrunner_mozjs.cmk
+index 636bcc1..21072db 100644
+--- a/libproxy/cmake/modules/pacrunner_mozjs.cmk
++++ b/libproxy/cmake/modules/pacrunner_mozjs.cmk
+@@ -9,7 +9,7 @@ if(WIN32)
+ elseif(NOT APPLE)
+ option(WITH_MOZJS "Search for MOZJS package" ON)
+ if (WITH_MOZJS)
+- pkg_search_module(MOZJS mozjs185>=1.8.5)
++ pkg_search_module(MOZJS mozjs185)
+ if(MOZJS_FOUND)
+ include_directories(${MOZJS_INCLUDE_DIRS})
+ link_directories(${MOZJS_LIBRARY_DIRS})
+--
+1.7.12.3
+
diff --git a/net-libs/libproxy/libproxy-0.4.10.ebuild b/net-libs/libproxy/libproxy-0.4.10.ebuild
new file mode 100644
index 000000000000..46de508df12b
--- /dev/null
+++ b/net-libs/libproxy/libproxy-0.4.10.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.10.ebuild,v 1.1 2012/10/16 08:04:33 tetromino Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit cmake-utils eutils mono python
+
+DESCRIPTION="Library for automatic proxy configuration management"
+HOMEPAGE="http://code.google.com/p/libproxy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="gnome kde mono networkmanager +pac perl python spidermonkey test +webkit"
+REQUIRED_USE="pac? ( || ( spidermonkey webkit ) )"
+
+# NOTE: mozjs/spidermonkey might still cause problems like #373397 ?
+# NOTE: webkit-gtk:3, not :2, needed for libjavascriptcoregtk support
+RDEPEND="gnome? ( >=dev-libs/glib-2.26:2 )
+ kde? ( >=kde-base/kdelibs-4.4.5 )
+ mono? ( dev-lang/mono )
+ networkmanager? ( net-misc/networkmanager )
+ perl? ( dev-lang/perl )
+ pac? (
+ spidermonkey? ( >=dev-lang/spidermonkey-1.8.5 )
+ webkit? ( >=net-libs/webkit-gtk-1.6:3 )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Gentoo's spidermonkey doesn't set Version: in mozjs185.pc
+ epatch "${FILESDIR}/${PN}-0.4.10-mozjs185.pc.patch"
+
+ # get-pac-test freezes when run by the ebuild, succeeds when building
+ # manually; virtualx.eclass doesn't help :(
+ epatch "${FILESDIR}/${PN}-0.4.10-disable-pac-test.patch"
+}
+
+src_configure() {
+ # WITH_VALA just copies the .vapi file over and needs no deps,
+ # hence always enable it unconditionally
+ local mycmakeargs=(
+ -DPERL_VENDORINSTALL=ON
+ -DCMAKE_C_FLAGS="${CFLAGS}"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
+ $(cmake-utils_use_with gnome GNOME3)
+ $(cmake-utils_use_with kde KDE4)
+ $(cmake-utils_use_with mono DOTNET)
+ $(cmake-utils_use_with networkmanager NM)
+ $(cmake-utils_use_with perl PERL)
+ $(cmake-utils_use_with python PYTHON)
+ $(cmake-utils_use_with spidermonkey MOZJS)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with webkit WEBKIT3)
+ -DWITH_VALA=ON
+ $(cmake-utils_use test BUILD_TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+}
diff --git a/net-libs/libproxy/libproxy-0.4.6-r3.ebuild b/net-libs/libproxy/libproxy-0.4.6-r3.ebuild
index c12212a4cc17..c6628b5531f5 100644
--- a/net-libs/libproxy/libproxy-0.4.6-r3.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r3.ebuild,v 1.11 2012/05/05 02:54:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r3.ebuild,v 1.12 2012/10/16 08:04:33 tetromino Exp $
EAPI=3
PYTHON_DEPEND="python? 2:2.6"
@@ -11,7 +11,7 @@ DESCRIPTION="Library for automatic proxy configuration management"
HOMEPAGE="http://code.google.com/p/libproxy/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-linux"
IUSE="gnome kde mono networkmanager perl python test"
diff --git a/net-libs/libproxy/libproxy-0.4.7.ebuild b/net-libs/libproxy/libproxy-0.4.7.ebuild
index d7a6d88a1c63..ffb69d791e57 100644
--- a/net-libs/libproxy/libproxy-0.4.7.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.7.ebuild,v 1.11 2012/05/26 08:57:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.7.ebuild,v 1.12 2012/10/16 08:04:33 tetromino Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -11,7 +11,7 @@ DESCRIPTION="Library for automatic proxy configuration management"
HOMEPAGE="http://code.google.com/p/libproxy/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-linux"
IUSE="gnome kde mono networkmanager perl python test"
diff --git a/net-libs/libproxy/metadata.xml b/net-libs/libproxy/metadata.xml
index 5143ad097e69..d09e931d4e5a 100644
--- a/net-libs/libproxy/metadata.xml
+++ b/net-libs/libproxy/metadata.xml
@@ -9,6 +9,12 @@
<flag name="gnome">Enable support for reading proxy settings from
GNOME</flag>
<flag name="kde">Enable support for reading proxy settings from KDE</flag>
+ <flag name="pac">Enable support for PAC and WPAD (proxy auto-config and
+ autodiscovery)</flag>
+ <flag name="spidermonkey">Use libmozjs from
+ <pkg>dev-lang/spidermonkey</pkg> for PAC parsing</flag>
+ <flag name="webkit">Use libjavascriptcoregtk from
+ <pkg>net-libs/webkit-gtk</pkg> for PAC parsing</flag>
</use>
<upstream>
<remote-id type="google-code">libproxy</remote-id>