summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-02-20 22:54:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-02-20 22:54:32 +0000
commit66d0e2922b9924305d962202b7b37d5ef782b712 (patch)
tree9b803669c17e75c1e5877aa67f7e3a16494893d3 /net-libs/libsoup-gnome
parentAdd ~arm-linux keyword. (diff)
downloadgentoo-2-66d0e2922b9924305d962202b7b37d5ef782b712.tar.gz
gentoo-2-66d0e2922b9924305d962202b7b37d5ef782b712.tar.bz2
gentoo-2-66d0e2922b9924305d962202b7b37d5ef782b712.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs/libsoup-gnome')
-rw-r--r--net-libs/libsoup-gnome/ChangeLog10
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.40.3.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/net-libs/libsoup-gnome/ChangeLog b/net-libs/libsoup-gnome/ChangeLog
index cc0d53c7dea7..ea055ac8e58a 100644
--- a/net-libs/libsoup-gnome/ChangeLog
+++ b/net-libs/libsoup-gnome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libsoup-gnome
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.83 2012/12/17 05:15:18 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.84 2013/02/20 22:54:32 eva Exp $
+
+*libsoup-gnome-2.40.3 (20 Feb 2013)
+
+ 20 Feb 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +libsoup-gnome-2.40.3.ebuild:
+ Version bump.
*libsoup-gnome-2.40.2 (17 Dec 2012)
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.40.3.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.40.3.ebuild
new file mode 100644
index 000000000000..5f34e9700c9b
--- /dev/null
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.40.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.40.3.ebuild,v 1.1 2013/02/20 22:54:32 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+MY_PN=${PN/-gnome}
+MY_P=${MY_PN}-${PV}
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="GNOME plugin for libsoup"
+HOMEPAGE="http://live.gnome.org/LibSoup"
+SRC_URI="${SRC_URI//-gnome}"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+IUSE="debug +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-solaris"
+
+RDEPEND="~net-libs/libsoup-${PV}[introspection?]
+ || ( gnome-base/libgnome-keyring <gnome-base/gnome-keyring-2.29.4 )
+ dev-db/sqlite:3=
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Use lib present on the system
+ epatch "${FILESDIR}"/${PN}-2.40.2-system-lib.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ gnome2_src_configure \
+ --disable-static \
+ --disable-tls-check \
+ $(use_enable introspection) \
+ --with-libsoup-system \
+ --with-gnome \
+ --without-apache-httpd
+}