summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-04-03 16:04:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-04-03 16:04:20 +0000
commitea3d734cd6793adb429fa3c9d27c15ce1331691f (patch)
treec147a4f17d771f4bacc0c32e24af6e6cc8e270de /net-libs/libtorrent
parentAvoid maintainer-mode triggered automake. (diff)
downloadgentoo-2-ea3d734cd6793adb429fa3c9d27c15ce1331691f.tar.gz
gentoo-2-ea3d734cd6793adb429fa3c9d27c15ce1331691f.tar.bz2
gentoo-2-ea3d734cd6793adb429fa3c9d27c15ce1331691f.zip
Bump, fix for upstream issue #2505 included
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog10
-rw-r--r--net-libs/libtorrent/files/download_constructor.diff21
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.7.ebuild51
3 files changed, 80 insertions, 2 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index ac073ac8ba7e..f40efa20c106 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.154 2010/12/08 02:50:00 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.155 2011/04/03 16:04:20 patrick Exp $
+
+*libtorrent-0.12.7 (03 Apr 2011)
+
+ 03 Apr 2011; Patrick Lauer <patrick@gentoo.org> +libtorrent-0.12.7.ebuild,
+ +files/download_constructor.diff:
+ Bump, fix for upstream issue #2505 included
08 Dec 2010; Mike Frysinger <vapier@gentoo.org> libtorrent-0.12.6.ebuild:
Fix building on systems that lack posix_fallocate().
diff --git a/net-libs/libtorrent/files/download_constructor.diff b/net-libs/libtorrent/files/download_constructor.diff
new file mode 100644
index 000000000000..e806cabb64b2
--- /dev/null
+++ b/net-libs/libtorrent/files/download_constructor.diff
@@ -0,0 +1,21 @@
+--- src/download/download_constructor.cc 2011-03-08 17:48:43.000000000 +0300
++++ src/download/download_constructor.cc.new 2011-03-08 17:36:42.000000000 +0300
+@@ -97,7 +97,17 @@
+
+ parse_name(b.get_key("info"));
+ parse_info(b.get_key("info"));
+-
++
++ // hack, quick fix for #2505
++ if (b.has_key_list("announce-list"))
++ if (b.get_key_list("announce-list").empty()) {
++ b.erase_key("announce-list");
++ } else {
++ Object::list_type & l = b.get_key_list("announce-list");
++ if (l.size() == 1 && !l.begin()->is_list()) {
++ b.erase_key("announce-list");
++ }
++ }
+ parse_tracker(b);
+ }
+
diff --git a/net-libs/libtorrent/libtorrent-0.12.7.ebuild b/net-libs/libtorrent/libtorrent-0.12.7.ebuild
new file mode 100644
index 000000000000..880c8f03476d
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.7.ebuild,v 1.1 2011/04/03 16:04:20 patrick Exp $
+
+EAPI=2
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.12.6-gcc44.patch
+ epatch "${FILESDIR}"/download_constructor.diff
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}