summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-08 04:20:15 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-08 04:20:15 +0000
commitf9f2459e0dfeed3af837a01a389a2f9514e4fc88 (patch)
treeda14aeb0589b57e127275ab93cf5fedcc468969f /net-libs/libvncserver
parentBump, remove old, partial fix for #404195 (diff)
downloadgentoo-2-f9f2459e0dfeed3af837a01a389a2f9514e4fc88.tar.gz
gentoo-2-f9f2459e0dfeed3af837a01a389a2f9514e4fc88.tar.bz2
gentoo-2-f9f2459e0dfeed3af837a01a389a2f9514e4fc88.zip
Adjust patch from previous commit so that we don't break the wire protocol.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libvncserver')
-rw-r--r--net-libs/libvncserver/ChangeLog9
-rw-r--r--net-libs/libvncserver/files/libvncserver-memcpy.patch9
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.8.2-r2.ebuild (renamed from net-libs/libvncserver/libvncserver-0.9.8.2-r1.ebuild)2
3 files changed, 14 insertions, 6 deletions
diff --git a/net-libs/libvncserver/ChangeLog b/net-libs/libvncserver/ChangeLog
index cd6963757a3e..c13298463419 100644
--- a/net-libs/libvncserver/ChangeLog
+++ b/net-libs/libvncserver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libvncserver
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/ChangeLog,v 1.51 2012/03/08 03:32:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/ChangeLog,v 1.52 2012/03/08 04:20:15 floppym Exp $
+
+*libvncserver-0.9.8.2-r2 (08 Mar 2012)
+
+ 08 Mar 2012; Mike Gilbert <floppym@gentoo.org>
+ +libvncserver-0.9.8.2-r2.ebuild, -libvncserver-0.9.8.2-r1.ebuild,
+ files/libvncserver-memcpy.patch:
+ Adjust patch from previous commit so that we don't break the wire protocol.
*libvncserver-0.9.8.2-r1 (08 Mar 2012)
diff --git a/net-libs/libvncserver/files/libvncserver-memcpy.patch b/net-libs/libvncserver/files/libvncserver-memcpy.patch
index af5289e68d21..9d30e7e3122a 100644
--- a/net-libs/libvncserver/files/libvncserver-memcpy.patch
+++ b/net-libs/libvncserver/files/libvncserver-memcpy.patch
@@ -3,21 +3,22 @@ https://bugs.gentoo.org/show_bug.cgi?id=329031
--- libvncserver/tightvnc-filetransfer/filetransfermsg.c
+++ libvncserver/tightvnc-filetransfer/filetransfermsg.c
-@@ -393,7 +393,7 @@
+@@ -393,7 +393,8 @@
CreateFileDownloadZeroSizeDataMsg(unsigned long mTime)
{
FileTransferMsg fileDownloadZeroSizeDataMsg;
- int length = sz_rfbFileDownloadDataMsg + sizeof(int);
-+ int length = sz_rfbFileDownloadDataMsg + sizeof(mTime);
++ uint32_t mTime32 = (uint32_t)mTime;
++ int length = sz_rfbFileDownloadDataMsg + sizeof(mTime32);
rfbFileDownloadDataMsg *pFDD = NULL;
char *pFollow = NULL;
-@@ -413,7 +413,7 @@
+@@ -413,7 +414,7 @@
pFDD->compressedSize = Swap16IfLE(0);
pFDD->realSize = Swap16IfLE(0);
- memcpy(pFollow, &mTime, sizeof(unsigned long));
-+ memcpy(pFollow, &mTime, sizeof(mTime));
++ memcpy(pFollow, &mTime, sizeof(mTime32));
fileDownloadZeroSizeDataMsg.data = pData;
fileDownloadZeroSizeDataMsg.length = length;
diff --git a/net-libs/libvncserver/libvncserver-0.9.8.2-r1.ebuild b/net-libs/libvncserver/libvncserver-0.9.8.2-r2.ebuild
index 635ba25ad8c7..65cb61feb5c6 100644
--- a/net-libs/libvncserver/libvncserver-0.9.8.2-r1.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.8.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/libvncserver-0.9.8.2-r1.ebuild,v 1.1 2012/03/08 03:32:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/libvncserver-0.9.8.2-r2.ebuild,v 1.1 2012/03/08 04:20:15 floppym Exp $
EAPI="4"