summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-05 03:05:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-05 03:05:37 +0000
commit4964972f0b09437d83361dde841961f44d3aee31 (patch)
tree9b63cbd62d8ebbdef9a0c0760a0994b767d6bd31 /net-libs/nodejs
parentCleanup old. (diff)
downloadgentoo-2-4964972f0b09437d83361dde841961f44d3aee31.tar.gz
gentoo-2-4964972f0b09437d83361dde841961f44d3aee31.tar.bz2
gentoo-2-4964972f0b09437d83361dde841961f44d3aee31.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog11
-rw-r--r--net-libs/nodejs/nodejs-0.10.10.ebuild65
-rw-r--r--net-libs/nodejs/nodejs-0.10.13.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.10.15.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.10.18.ebuild (renamed from net-libs/nodejs/nodejs-0.10.16-r1.ebuild)2
-rw-r--r--net-libs/nodejs/nodejs-0.11.2.ebuild81
-rw-r--r--net-libs/nodejs/nodejs-0.11.4.ebuild84
-rw-r--r--net-libs/nodejs/nodejs-0.11.7.ebuild (renamed from net-libs/nodejs/nodejs-0.11.5.ebuild)2
8 files changed, 12 insertions, 369 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index d9e3b69dca24..04ab18038b1c 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.100 2013/08/26 01:55:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.101 2013/09/05 03:05:37 patrick Exp $
+
+*nodejs-0.11.7 (05 Sep 2013)
+*nodejs-0.10.18 (05 Sep 2013)
+
+ 05 Sep 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.18.ebuild,
+ +nodejs-0.11.7.ebuild, -nodejs-0.10.10.ebuild, -nodejs-0.10.13.ebuild,
+ -nodejs-0.10.15.ebuild, -nodejs-0.10.16-r1.ebuild, -nodejs-0.11.2.ebuild,
+ -nodejs-0.11.4.ebuild, -nodejs-0.11.5.ebuild:
+ Bump
*nodejs-0.11.6 (26 Aug 2013)
diff --git a/net-libs/nodejs/nodejs-0.10.10.ebuild b/net-libs/nodejs/nodejs-0.10.10.ebuild
deleted file mode 100644
index 63edbd9b7ed7..000000000000
--- a/net-libs/nodejs/nodejs-0.10.10.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.10.ebuild,v 1.1 2013/06/05 07:26:50 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{5,6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE=""
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}
- virtual/python-json"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.13.ebuild b/net-libs/nodejs/nodejs-0.10.13.ebuild
deleted file mode 100644
index 35116db8d0cc..000000000000
--- a/net-libs/nodejs/nodejs-0.10.13.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.13.ebuild,v 1.1 2013/07/19 06:52:01 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{5,6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}
- virtual/python-json"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.15.ebuild b/net-libs/nodejs/nodejs-0.10.15.ebuild
deleted file mode 100644
index 519fc1628668..000000000000
--- a/net-libs/nodejs/nodejs-0.10.15.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.15.ebuild,v 1.1 2013/08/01 04:21:25 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{5,6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}
- virtual/python-json"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out mksnapshot
- pax-mark m out/Release/mksnapshot
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}"
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.10.16-r1.ebuild b/net-libs/nodejs/nodejs-0.10.18.ebuild
index 1c47d8b09ed2..a3cec2d98b84 100644
--- a/net-libs/nodejs/nodejs-0.10.16-r1.ebuild
+++ b/net-libs/nodejs/nodejs-0.10.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.16-r1.ebuild,v 1.1 2013/08/17 09:35:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.18.ebuild,v 1.1 2013/09/05 03:05:37 patrick Exp $
EAPI=5
diff --git a/net-libs/nodejs/nodejs-0.11.2.ebuild b/net-libs/nodejs/nodejs-0.11.2.ebuild
deleted file mode 100644
index 2db3b6be2fc8..000000000000
--- a/net-libs/nodejs/nodejs-0.11.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.2.ebuild,v 1.1 2013/05/21 05:23:40 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE=""
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- # Use target arch detection logic, see v8-3.18 ebuilds
- case ${CHOST} in
- i?86-*)
- myarch="ia32"
- myconf+=" -Dv8_target_arch=ia32" ;;
- x86_64-*)
- if [[ $ABI = x86 ]] ; then
- myarch="ia32"
- else
- myarch="x64"
- fi ;;
- arm*-*)
- myarch="arm"
- ;;
- *) die "Unrecognized CHOST: ${CHOST}"
- esac
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out "mksnapshot.${myarch}"
- pax-mark m "out/Release/mksnapshot.${myarch}"
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}" /usr
-
- dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.11.4.ebuild b/net-libs/nodejs/nodejs-0.11.4.ebuild
deleted file mode 100644
index 7914aaa88b7b..000000000000
--- a/net-libs/nodejs/nodejs-0.11.4.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.4.ebuild,v 1.1 2013/07/19 06:52:01 patrick Exp $
-
-EAPI=5
-
-# has known failures. sigh.
-RESTRICT="test"
-
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-any-r1 pax-utils
-
-DESCRIPTION="Evented IO for V8 Javascript"
-HOMEPAGE="http://nodejs.org/"
-SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-IUSE="+npm"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/node-v${PV}
-
-src_prepare() {
- # fix compilation on Darwin
- # http://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # make sure we use python2.* while using gyp
- sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
- # less verbose install output (stating the same as portage, basically)
- sed -i -e "/print/d" tools/install.py || die
-}
-
-src_configure() {
- local myconf=""
- ! use npm && myconf="--without-npm"
-
- # Use target arch detection logic, see v8-3.18 ebuilds
- case ${CHOST} in
- i?86-*)
- myarch="ia32"
- myconf+=" -Dv8_target_arch=ia32" ;;
- x86_64-*)
- if [[ $ABI = x86 ]] ; then
- myarch="ia32"
- else
- myarch="x64"
- fi ;;
- arm*-*)
- myarch="arm"
- ;;
- *) die "Unrecognized CHOST: ${CHOST}"
- esac
-
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
- --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
-}
-
-src_compile() {
- emake out/Makefile
- emake -C out "mksnapshot.${myarch}"
- pax-mark m "out/Release/mksnapshot.${myarch}"
- emake
-}
-
-src_install() {
- "${PYTHON}" tools/install.py install "${D}" /usr
-
- use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
- rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
- rm -rf "${ED}"/usr/lib/dtrace
-
- pax-mark -m "${ED}"/usr/bin/node
-}
-
-src_test() {
- "${PYTHON}" tools/test.py --mode=release simple message || die
-}
diff --git a/net-libs/nodejs/nodejs-0.11.5.ebuild b/net-libs/nodejs/nodejs-0.11.7.ebuild
index 11a728e6e398..18e55ebe0726 100644
--- a/net-libs/nodejs/nodejs-0.11.5.ebuild
+++ b/net-libs/nodejs/nodejs-0.11.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.5.ebuild,v 1.1 2013/08/23 09:12:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.7.ebuild,v 1.1 2013/09/05 03:05:37 patrick Exp $
EAPI=5