summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-29 19:35:00 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-29 19:35:00 +0000
commit57250e67af151d0794408dbee9210ae148d90ae9 (patch)
tree07b8ed152eacb39b5a32e379ed80973c97f12615 /net-libs/rb_libtorrent
parentFix build with gcc 4.4, bug #272851 by hirakendu <hirakendu@gmail.com> (diff)
downloadgentoo-2-57250e67af151d0794408dbee9210ae148d90ae9.tar.gz
gentoo-2-57250e67af151d0794408dbee9210ae148d90ae9.tar.bz2
gentoo-2-57250e67af151d0794408dbee9210ae148d90ae9.zip
Add patch to fix the tests complementing the CVE patch. Remove no longer used patch from filesdir.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog9
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-0.13-CVE-2009-1760-test-fix.patch23
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch21
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild4
4 files changed, 33 insertions, 24 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 2f2943e89ed6..ac13d513af90 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.61 2009/06/29 00:06:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.62 2009/06/29 19:34:59 yngwin Exp $
+
+ 29 Jun 2009; Ben de Groot <yngwin@gentoo.org>
+ rb_libtorrent-0.13-r1.ebuild,
+ +files/rb_libtorrent-0.13-CVE-2009-1760-test-fix.patch,
+ -files/rb_libtorrent-0.14.1-ax_python_path.patch:
+ Add patch to fix the tests complementing the CVE patch. Remove no longer
+ used patch from filesdir.
29 Jun 2009; Ben de Groot <yngwin@gentoo.org>
rb_libtorrent-0.13-r1.ebuild, -rb_libtorrent-0.14.4.ebuild:
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-0.13-CVE-2009-1760-test-fix.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-0.13-CVE-2009-1760-test-fix.patch
new file mode 100644
index 000000000000..9ab1ea80e210
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-0.13-CVE-2009-1760-test-fix.patch
@@ -0,0 +1,23 @@
+diff --git a/test/test_primitives.cpp b/test/test_primitives.cpp
+index 22efb0a..b0d11d1 100644
+--- a/test/test_primitives.cpp
++++ b/test/test_primitives.cpp
+@@ -17,6 +17,9 @@
+ using namespace libtorrent;
+ using namespace boost::tuples;
+ using boost::bind;
++namespace libtorrent {
++ fs::path sanitize_path(fs::path const& p);
++}
+
+ tuple<int, int> feed_bytes(http_parser& parser, char const* str)
+ {
+@@ -255,7 +258,7 @@ int test_main()
+ torrent["info"] = info;
+ torrent_info ti2(torrent);
+ std::cerr << ti2.name() << std::endl;
+- TEST_CHECK(ti2.name() == "test3");
++ TEST_CHECK(ti2.name() == "test1/test2/test3");
+
+ info["name.utf-8"] = "test2/../test3/.././../../test4";
+ torrent["info"] = info;
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch
deleted file mode 100644
index 0d1f48ef5310..000000000000
--- a/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Source: Santiago M. Mola <coldwind@gentoo.org>
-Upstream: The 'locate' part is merged.
-Reason: Support Python 2.6 and stop using locate to find Python headers.
---- libtorrent-rasterbar-0.14.1.orig/m4/ax_python.m4 2008-12-28 15:07:42.000000000 +0100
-+++ libtorrent-rasterbar-0.14.1/m4/ax_python.m4 2008-12-28 18:48:54.000000000 +0100
-@@ -58,13 +58,13 @@
- AC_DEFUN([AX_PYTHON],
- [AC_MSG_CHECKING(for python build information)
- AC_MSG_RESULT([])
--for python in python2.5 python2.4 python2.3 python2.2 python2.1 python; do
-+for python in python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
- AC_CHECK_PROGS(PYTHON_BIN, [$python])
- ax_python_bin=$PYTHON_BIN
- if test x$ax_python_bin != x; then
- AC_CHECK_LIB($ax_python_bin, main, ax_python_lib=$ax_python_bin, ax_python_lib=no)
- AC_CHECK_HEADER([$ax_python_bin/Python.h],
-- [[ax_python_header=`locate $ax_python_bin/Python.h | sed -e s,/Python.h,,`]],
-+ [[ax_python_header=/usr/include/$ax_python_bin]],
- ax_python_header=no)
- if test $ax_python_lib != no; then
- if test $ax_python_header != no; then
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild
index 5b0e78265026..23b5f34af855 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild,v 1.2 2009/06/29 00:06:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild,v 1.3 2009/06/29 19:34:59 yngwin Exp $
EAPI="2"
inherit eutils flag-o-matic
-RESTRICT="test" # tests break due to the CVE patch :(
MY_P=${P/rb_/}
S=${WORKDIR}/${MY_P}
@@ -25,6 +24,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-CVE-2009-1760.patch # bug 273156
+ epatch "${FILESDIR}"/${P}-CVE-2009-1760-test-fix.patch
epatch "${FILESDIR}"/${P}-boost-1.37.patch # bug 270447
epatch "${FILESDIR}"/${P}-gcc44.patch
}