summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-07-14 14:22:47 +0000
committerBen de Groot <yngwin@gentoo.org>2012-07-14 14:22:47 +0000
commitab916a46913e1c41d4765b76fc732347f3a43d57 (patch)
treeb87442b6d5e2c46a72ff21fa67bd19a187c6891e /net-libs/rb_libtorrent
parentKeyword ~ppc64 (diff)
downloadgentoo-2-ab916a46913e1c41d4765b76fc732347f3a43d57.tar.gz
gentoo-2-ab916a46913e1c41d4765b76fc732347f3a43d57.tar.bz2
gentoo-2-ab916a46913e1c41d4765b76fc732347f3a43d57.zip
Version bump
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.2.ebuild77
2 files changed, 83 insertions, 2 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 82b2fb48dcf1..3ca4987db3bd 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.130 2012/06/16 09:57:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.131 2012/07/14 14:22:47 yngwin Exp $
+
+*rb_libtorrent-0.16.2 (14 Jul 2012)
+
+ 14 Jul 2012; Ben de Groot <yngwin@gentoo.org> +rb_libtorrent-0.16.2.ebuild:
+ Version bump
16 Jun 2012; Markos Chandras <hwoarang@gentoo.org>
-rb_libtorrent-0.15.6.ebuild, -rb_libtorrent-0.15.8.ebuild,
@@ -670,4 +675,3 @@
08 Jan 2007; <armin@gentoo.org> +metadata.xml, +rb_libtorrent-0.11.ebuild:
New ebuild, from bug 148667
-
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.2.ebuild
new file mode 100644
index 000000000000..bd23b48505ec
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.2.ebuild,v 1.1 2012/07/14 14:22:47 yngwin Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit multilib python versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.48[python?]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ # use multi-threading versions of boost libs
+ local BOOST_LIBS="--with-boost-system=boost_system-mt \
+ --with-boost-python=boost_python-${PYTHON_ABI}-mt"
+ # detect boost version and location, bug 295474
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ local LOGGING
+ use debug && LOGGING="--enable-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
+ $(use_enable static-libs static) \
+ ${LOGGING} \
+ --with-boost=${BOOST_INC} \
+ --with-boost-libdir=${BOOST_LIB} \
+ ${BOOST_LIBS}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README
+ if use doc; then
+ dohtml docs/*
+ fi
+}